# Table of Contents

1. **INTRODUCING GUI MACHINE** ................................................................................................................................................. 6
   1.1. **ABOUT THE PROGRAM** .................................................................................................................................................... 6
   1.2. **HOW TO USE THIS MANUAL** ....................................................................................................................................... 8
   1.3. **SUPPORT** ........................................................................................................................................................................ 8

2. **INSTALLATION INSTRUCTIONS** ........................................................................................................................................... 9
   2.1. **SYSTEM REQUIREMENTS** ................................................................................................................................................ 9
   2.2. **INSTALLATION** ............................................................................................................................................................... 10
   2.3. **LICENSING** ....................................................................................................................................................................... 16
      2.3.1. Online licensing.............................................................................................................................................................. 16
      2.3.2. Activating the license without Internet connection ........................................................................................................... 21
      2.3.3. Activating and deactivating the license ................................................................................................................................ 24
   2.4. **LAUNCH** .......................................................................................................................................................................... 25
   2.5. **UNINSTALLATION** ............................................................................................................................................................ 30

3. **WORKSPACE** ........................................................................................................................................................................ 32
   3.1. **GENERAL INFORMATION ABOUT GUI MACHINE WORKSPACE** ....................................................................................... 32
   3.2. **WORKSPACE CUSTOMIZATION** ...................................................................................................................................... 33
      3.2.1. Hide/show tools ............................................................................................................................................................ 33
      3.2.2. The Context Menu of the Panels .................................................................................................................................... 33
   3.3. **THE MAIN MENU** ............................................................................................................................................................ 38
      3.3.1. The File menu ............................................................................................................................................................... 38
      3.3.2. The Edit menu ............................................................................................................................................................... 39
         3.3.2.1. Object Text Format .................................................................................................................................................... 39
         3.3.2.2. The aligning of the objects ......................................................................................................................................... 41
      3.3.3. Standard Menu ............................................................................................................................................................. 44
      3.3.4. Extended menu ............................................................................................................................................................... 45
      3.3.5. The Shapes menu ............................................................................................................................................................ 45
      3.3.6. Vaadin menu ................................................................................................................................................................. 46
      3.3.7. Tools and Frames menu ................................................................................................................................................... 46
         3.3.7.1. The display of actions .................................................................................................................................................. 47
         3.3.7.2. Objects view customization ......................................................................................................................................... 47
      3.3.8. The Help Menu ............................................................................................................................................................. 48
   3.4. **EDIT AREA** ....................................................................................................................................................................... 49
      3.4.1. Edit Area ........................................................................................................................................................................ 50
         3.4.1.1. Rulers ........................................................................................................................................................................ 51
         3.4.1.2. The grid ....................................................................................................................................................................... 52
         3.4.1.3. Guidelines ................................................................................................................................................................. 52
      3.4.2. Settings for prototype preview ......................................................................................................................................... 53
         3.4.2.1. Settings for the edit area .............................................................................................................................................. 54
         3.4.2.2. Print settings ............................................................................................................................................................... 54
         3.4.2.3. Settings for the appearance of the edit area .................................................................................................................. 56
      3.4.3. Page manager ................................................................................................................................................................. 58
4. TOOLS ........................................................................................................................................................................ 60

4.1. COMPONENTS ............................................................................................................................................................ 60

4.2. OBJECT PROPERTIES .................................................................................................................................................. 69

4.2.1. The Description of Object Properties .................................................................................................................. 69

4.2.1.1. Standard Properties .............................................................................................................................................. 69

4.2.1.2. Properties for Editor .............................................................................................................................................. 71

4.2.1.2. Properties for buttons ........................................................................................................................................ 71

4.2.1.3. Properties for images ........................................................................................................................................ 73

4.2.1.4. Properties for separators .................................................................................................................................. 74

4.2.1.5. Properties for layouts ........................................................................................................................................ 74

4.2.1.6. Properties for panels ........................................................................................................................................ 75

4.2.1.7. Properties for split panels .................................................................................................................................. 76

4.2.1.8. Properties for tabbed panels .............................................................................................................................. 76

4.2.1.9. Properties for text fields and areas ..................................................................................................................... 77

4.2.1.10. Properties for the placeholder ......................................................................................................................... 78

4.2.1.11. Properties for the progress bar ......................................................................................................................... 79

4.2.1.12. Properties for lists ............................................................................................................................................... 79

4.2.1.13. Properties for the spinner ................................................................................................................................... 80

4.2.1.14. Properties for the slider ..................................................................................................................................... 80

4.2.1.15. Properties for the scrollbar ................................................................................................................................ 81

4.2.1.16. Properties for the tree ......................................................................................................................................... 82

4.2.1.17. Properties for tables ............................................................................................................................................ 83

4.2.1.18. Properties for windows ..................................................................................................................................... 84

4.2.1.19. Properties for menus .......................................................................................................................................... 85

4.2.1.20. Properties for Google maps ............................................................................................................................ 86

4.2.1.21. Properties for collapsible panes ....................................................................................................................... 87

4.2.1.22. Properties for clocks ........................................................................................................................................... 88

4.2.1.23. Properties for the audio player ........................................................................................................................ 89

4.2.1.24. Properties for the connector object ................................................................................................................ 89

4.2.1.25. Properties for shapes .......................................................................................................................................... 90

4.2.1.26. Properties for data fields and calendars ........................................................................................................... 90

4.2.1.27. Properties for the tray icon ................................................................................................................................ 91

4.2.2. Auxiliary tools .............................................................................................................................................................. 92

4.2.2.1. HTML/Text editor ............................................................................................................................................... 92

4.2.2.2. Image selection tool ............................................................................................................................................ 96

4.2.2.3. Editing tabs .......................................................................................................................................................... 101

4.2.2.4. Table editor .......................................................................................................................................................... 102

4.2.2.5. Tree editor ............................................................................................................................................................ 103

4.2.2.6. List editor ............................................................................................................................................................ 103

4.2.2.7. Checkbox editor ................................................................................................................................................... 104

4.2.2.8. Editing popup menus ........................................................................................................................................... 105

4.2.2.9. Menu editor .......................................................................................................................................................... 108

4.2.2.10. Selecting in a cursor ........................................................................................................................................... 110

4.3. LAYERS ........................................................................................................................................................................ 112

4.3.1. Tools for working with layers .................................................................................................................................. 114

4.4. HISTORY ........................................................................................................................................................................ 116

4.5. TEMPLATES .................................................................................................................................................................... 119

4.5.1. Importing/exporting templates ............................................................................................................................... 120

5. WORKING IN GUI MACHINE ........................................................................................................................................... 121

5.1. GENERAL INFORMATION ............................................................................................................................................... 121

5.2. WORKING WITH STATIC LAYOUTS .......................................................................................................................... 125
1. Introducing GUI Machine

1.1. About the program

The program **GUI Machine** is designed for creating prototypes of desktop and web interfaces.

*Graphical User Interface (GUI) is the space for human-computer interaction allowing the user interact with the computer with images rather than text commands.*

The program is designed for all specialists taking part in software development (programmers, analysts, GUI designers, managers). Prototypes created in GUI machine are characterized by high fidelity and interactivity. GUI Machine is an intuitive tool. No programming is necessary for the creation of prototypes.

**The functionality of GUI Machine**

**GUI Machine** comprises a large set of functions:

- Creation of interfaces for different types of applications:
  - desktop applications;
  - web applications;
  - mobile applications

- Creation of interactive graphical prototypes close to the original
- Interactive preview of prototypes, their parts and single objects
- Viewing prototypes with a free viewer without running the whole application
- Option for rapid interface redesign
- Rapid creation and structuring of screenshots
- Rapid editing of images used in projects
- Rollback of changes made
- Option for detailed customization for each object
- Creation of reusable templates
- Preview of interfaces in different operating systems styles
Key functions of GUI Machine

- Platforms supported:
  - Windows;
  - MacOS;
  - Linux.
- The application comprises a set of most widely components (ready-made interface elements) including Vaadin web components set.
- The application comprises special modules giving additional options for creating and editing prototypes
  - Image Editor
  - Print Screen — a screenshot making tool
  - Pixel Grabber — a special tool for defining display dots color in RGB format
- Interface languages: English and Russian

What platforms does GUI Machine support?

GUI Machine is a crossplatform application able to work on different operating systems:

- Windows;
- Linux;
- MacOS.
1.2. How to use this manual

Each item in the table of contents contains a hyperlink to the corresponding page. The page can be opened by clicking its number. Most of the programs used for viewing documents have a function of key words search. (For further information please consult the manual of the viewer you use).

1.3. Support

<table>
<thead>
<tr>
<th>Useful links</th>
</tr>
</thead>
<tbody>
<tr>
<td><a href="http://www.gui-machine.com/forum">http://www.gui-machine.com/forum</a> — GUI Machine Forum where you can ask any questions concerning work in GUI Machine and express your opinion about the program.</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Contacts</th>
</tr>
</thead>
<tbody>
<tr>
<td>You can contact us and ask all questions concerning the work in GUI Machine on our forum <a href="http://www.gui-machine.com/forum">http://www.gui-machine.com/forum</a> or by e-mail . <a href="mailto:gui@alee.com">gui@alee.com</a></td>
</tr>
</tbody>
</table>
2. Installation Instructions

2.1. System requirements

The system requirements for the work with the application are indicated in Table 1.

Table 1. System requirements

<table>
<thead>
<tr>
<th>Operating system*</th>
<th>CPU</th>
<th>Memory</th>
<th>HDD</th>
</tr>
</thead>
<tbody>
<tr>
<td>Windows XP, 2000, 2003, Vista, 7</td>
<td>1.5gHz/2+ GHz</td>
<td>512 M / 1024+ M</td>
<td>200+ Mb</td>
</tr>
<tr>
<td>Mac OS X 10.4 (Power PC or Intel)</td>
<td>1.5gHz/2+ GHz</td>
<td>512 M / 1024+ M</td>
<td>200+ Mb</td>
</tr>
<tr>
<td>Linux 2.2.6+, Solaris 10</td>
<td>1.5gHz/2+ GHz</td>
<td>512 M / 1024+ M</td>
<td>200+ Mb</td>
</tr>
</tbody>
</table>

* GUI Machine can work on any operating system supporting JDK 6 Update 20 and higher.

Notes:

➢ Parameters marked by «/» are interpreted as the minimal and the maximal ones.
➢ The parameter indicated without «/» is interpreted as the minimal one.

Attention!

Be aware that increasing the complexity of the project leads to the severization of the system requirements.
2.2. Installation

Execute the setup file Alee_GUI_Machine_xxx_1.5.4zzz, where xxx is for the operating system (Unix, Linux or MacOS) and zzz is the setup file extension.

You should then see the following window appear:

![Figure 1. Language selection](image1)

Select the language and press **OK**. Then you should see the welcome screen of the setup wizard:

![Figure 2. GUI Machine Setup Wizard](image2)
Press **Next** to continue.

The next screen will allow you to select the location where GUI Machine will be installed. The default location is the following:

X:\Program files\AleeGuiMachine\, where X is for the system drive letter.

![Destination directory selection](image)

**Figure 3. Destination directory selection**

Enter the location in **Destination directory** field or press **Browse...** button. The following screen should then appear:
Select the location and press **OK**.
Press **Next** to continue.
The next window will allow you to create file associations.
You can choose file extensions by selecting check boxes or by clicking buttons **Select all** and **Select none**.
After creating associations files will be opened by double-clicking. Press **Next** to continue. The next window will allow you to select the location for GUI Machine shortcuts:

![Figure 5. Creating file associations](image)

![Figure 6. Selection of the location for shortcuts](image)
Select the destination folder from the given list or type the name of the folder in the text field. You can also select the checkbox *Do not create a Start menu folder*. Press *Next* to complete the installation.

The next window will display the progress of GUI Machine installation:

![GUI Machine installation progress](image)

*Figure 7. GUI Machine installation*
When the installation is completed, the dialog box shown on figure 8 will appear. Press Finish to quit the setup wizard. Select the checkbox Run GUI Machine to launch the application right after pressing Finish.
2.3. Licensing

2.3.1. Online licensing
If your version of GUI Machine is not registered, after the first launch of the program the dialog of activation should appear on the screen (Figure 9). The program will offer you to visit the official site of GUI Machine in order to buy the license or to enter the license key:

![Figure 9. The activation of GUI Machine](image-url)
Click **Next** to enter the key. The following window should appear on the screen:

![GUI Machine - activation window](image)

**Figure 10. Entering the license key**

Enter the key in the text field and click **Next**.

**NB**: You can copy the key and enter it into the field by pressing **Ctrl+V**.

If the key you entered is incorrect, the following window should appear:
Figure 11. The information about the incorrect license key

Press **Previous** to retry. Enter the key and press **Next**. If the key is correct, the license will be activated and you will see the following window appear:
Figure 12. Information about the license
Press **Next**. The window containing the text of the license agreement should appear on the screen. Read the license; if you accept the terms, select the checkbox **I agree** and press **Next**.

![License agreement window](image)

**Figure 13. License agreement**
Then you should see the following window appear:

![Activation completed](image)

**Figure 14. Activation completed**

### 2.3.2. Activating the license without Internet connection

If your computer is not connected to the Internet or your Internet connection is limited, the program will offer you to activate the license manually:
The window with the activation code should appear on the screen:

![GUI Machine activation dialog box]

**Figure 15.** The dialog box offering to activate the license manually

Press **Next.** The window with the activation code should appear on the screen:
Figure 16. Activation code
Copy the code and paste it into a text file. Visit the site [http://www.gui-machine.com/lm/activate/](http://www.gui-machine.com/lm/activate/) from any computer connected to the Internet and press **Activate**. Enter the serial number in the field *The number of your license*. In the field “Activation code” enter the key you received. Press **Activate**. Then you will get the validation code. Enter the code into the dialog box. Your license will be activated.

### 2.3.3. Activating and deactivating the license

After the installation of the program you can read the information about the license. You can deactivate the license and activate it again. Select the item **Help** -> **About** program in the main menu. The window containing the information about the program will appear. To validate the license press **Validation**. To deactivate the license press **Deactivate**.

![License information](image)

**Figure 17. License information**
2.4. Launch

To start GUI Machine you need to go to the installation folder or any shortcut you may have chosen to create and double-click on the icon. After that, you will see the startup image with loading progress bars.

Then the following window should appear:

![To start working](image)

Figure 18. Starting work in GUI Machine

This window will allow you to select one of the following options:

- Create a new project;
- Open a recent project;
- Open project;
- Open a demo project;
- Start without a project.

Select the option and press **Next**.
Creating a new project

To create a new project select Create new project and press Next. Type the name of the project in the field Project name (by default the project is given the name GUI Machine Project). Then select the location for saving the project.

![Image of creating a new project]

**Figure 19. Creating a new project**

By default all projects are saved in C:\Documents and Settings\<User Name>\GUI Machine Project\. To change the location press the button <...>; then the standard window for selecting the location should appear.

If you need to create a separate folder within the selected directory, select the check box Select subdirectory.

Press Create to create the new project.

Open recent project

To open the last project you worked with select Open recent project. The last opened project will be loaded.
Loading a project

To load one of previously created projects select **Load project**. The standard file selection menu should appear:

![Open project window](image)

Figure 20. Opening a project

Select the project file and press **Open**.

Projects can also be loaded by dragging them to the edit area.
Loadig a demo project

After selecting this option you should see the following menu appear:

![Demo projects window](image)

Figure 21. Selecting a demo project to be loaded

Select the necessary project and press **Load project**. Projects can also be opened by double-clicking.

Start without a project

If you do not wish to create a new project or wish to start working with projects later, select the item **Start without a project**. The new file will not be created. After selecting this option the window with the tip of the day should appear. The tip of the day is a brief instruction or a brief description of some program functions.
Press **Previous** or **Next** to see other tips. If you do not want to see the tip of the day, deselect the checkbox **Show tips on startup**.
2.5. Uninstallation

To begin the uninstallation press the **Start** button. Select in the menu **All programs** → **GUI Machine** → **GUI Machine Uninstaller**.

If you did not create shortcuts, execute the file **Uninstall**.

![Uninstall Wizard](image)

*Figure 23. Launching the uninstall wizard*

The window of the uninstall wizard should appear on the screen. Press **Next** to continue. If you do not want to uninstall the program, press **Cancel**.
When the uninstall is finish, you should see the following window appear:

![GUI Machine Uninstall window](image)

Figure 24. Uninstall completed

Press **OK**. If the files of the program are not deleted, delete them manually.
3. Workspace

3.1. General information about GUI Machine workspace

GUI Machine workspace comprises the following elements:

- **The Main Menu** is located at the top of the application and includes eight root level items
- **The Edit Area** displays the current project
- The **Layers** panel allows to structure the objects used in the project
- The **Components** palette displays components which can be used in work
- The panel **Object Properties** displays the properties of a selected object (or that of a selected group of objects on Edit Area).
- The **Templates** panel shows templates used in the current project
- The **History** panel contains records concerning all manipulations made during the work
3.2. Workspace Customization

It is possible to move the tools, to change their size and close them if necessary with the help of the mouse.

3.2.1. Hide/show tools

To enlarge the space on the edit area the tools can be hidden. The tools can be shown/hidden in the two following ways:

➢ by selecting the item Tools and Frames → Hide all frames in the main menu;
➢ by pressing Ctrl+Alt+H;
➢ each tool can also be hidden by pressing the button Toggle auto-hide.

The tabs of the hidden tools are displayed on the workspace borders. They are displayed when hovered. The tools become hidden again when moving away the cursor. They can also be hidden by pressing the button at the top of the panel. To return the panel to the previous state press the button .

3.2.2. The Context Menu of the Panels

To activate the context menu move the cursor to the header of the panel and press the right mouse button(figure 26):

![Figure 26. The context menu for panels](image)
Select **Close** to close the panel. If you want to relocate the panel, select **Floating**. Then the panel can be moved on the workspace. To hide the panel select **Toggle auto-hide**. The tab of the panel will be displayed on the right border of the workspace. If you want to expand the panel, select **Maximize**.

### Jointing and disjointing panels

A **joint** is a set of panels displayed together (usually the panels are jointed vertically). Panels can be jointed and disjointed by dragging to the area.

- To fix the panel drag it to the joint and place it above or below or between other panels.
- To fix a group of panels drag it to the joint by the header.
- To delete a panel drag it out of the joint or double-click on the header.

![Figure 27. Jointing panels](image)
NB: If you do not want to join the panels please clear flag **Joint panels** in the menu shown on figure 32)

### Moving panels

When moving panels the zones where they can be placed are highlighted with gray.  
To fix the panel drag it to the gray zone. When dragged out of the zone the panel becomes floating.  
- To move the panel drag it by the header.  
- To move a group of panels or a stack of floating panels, drag it by the header.

### Adding and removing joints and panels

After removing all panels joints disappear. New joints are created by moving panels to drag zones located near the existing joints or thro the border of the workspace.
➢ To remove a panel click the button Close (the symbol x in the top-right corner) or remove (click) the icon of the panel in the menu **Tools and Frames → Frames Settings.**
➢ To add the panel click its icon in the menu **Tools and Frames → Frames Settings.**

![Figure 29. Moving panels](image)

**Panel groups manipulation**

➢ To add the panel to the group drag the tab of this panel to the selected drag area in the upper part of the group.
➢ To change the order of panels in the group drag the panel by the tab to the new place inside the group.
➢ To remove a panel from the group and make it floating drag it by the tab out of the group.
➢ To bring a panel to front click it by the tab.
➢ To drag the whole group drag it by the header located above the tabs.

**Floating panels**

A panel dragged out of the joint but not placed in the drag area will become floating. Floating panels can be placed in any point of the workspace. All panels can become floating after selecting the icon of the panel.
in the menu **Tools and Frames → Frames Settings.** Floating panels or panel groups can be united; then they will be moved as a unit when dragging the upper panel by the header. Panels being part of a joint cannot be put into stacks or relocated in such a manner.

### Creating a stack of floating panels

- To create a stack of floating panels move a panel by the tab to the drag area located in the lower part of the other panel.
- To change the order of panels in the stack move the panel by the header up or down. *NB. The tab should be placed above the narrow drag area between the panels, but not above the wide drag area at the panel header.*
- To remove the panel or a panel group from the stack and make it floating, drag it out of the stack by the tab.

### Resizing and collapsing panels

- To resize the panel move one of its borders or the resizing symbol located in the right lower corner.
- To change the width of all panels in the joint drag the capture area located in the upper left part of the joint.
- To collapse the panel, a group or a stack of panels click the Collapse button on the header panel.
### 3.3. The Main Menu

The main menu panel is shown on the figure below:

![The main menu](image)

The main menu includes 8 root items:

1. File;
2. Edit;
3. Standard;
4. Extended;
5. Shapes;
6. Vaadin;
7. Tools and Frames;

#### 3.3.1. The File menu

The File menu is shown on the figure below:

![The File menu](image)

It comprises the following items:

1. New project;
2. Open project;
3. Demo projects;
4. Save project;
5. Save as.....;
6. Export prototype;
7. Export images;
8. Export screenshots;
9. Project settings;
10. Program settings;
11. Print pages;
12. Show pages;
13. Print settings;
14. Close GUI Machine

3.3.2. The Edit menu

The Edit menu is shown on the following figure:

![Edit menu](image)

Figure 32. The Edit menu

This menu includes the following items:

1. Find (Find in project);
2. Edit:
   - New page;
   - Rename page;
   - Delete page
   - Add object;
   - Rename objects;
   - Delete objects;
   - Cut;
   - Copy;
   - Undo;
   - Insert;
   - Clone;
   - Repeat.
3. Format text (type selection and settings);
4. Align text;
5. Align objects;

3.3.2.1. Object Text Format

This tool is designed for formatting the text of an object or a group of objects. Select on the edit area the objects to format. Enter the necessary bold settings (bold type, size, style, color):
3.3.2.2. Text alignment

This function allows to align the text:

- **Vertical alignment:**
  - on top;
  - in the center;
  - at the bottom.

- **Horizontal alignment:**
  - on the left;
  - in the center;
  - on the right.

**NB:** Not all objects contain text. The operations of changing bold, color and text alignment are not applicable to all objects containing text. The format functions are not applicable to all objects. For some objects they are not applicable to full extent.

If format functions for an object selected on the edit area are blocked, the set of formatting tools is also blocked:
3.3.2.3. The aligning of the objects

To align the objects select the item Edit → Align objects in the main menu.

**Horizontal alignment**

These tools allow to align objects horizontally to the left, to the right or to the center. Select the objects and press click on the proper button.

![Horizontal alignment of objects](image)

**Vertical alignment**

These tools allow to align objects to the left, to the center and to the bottom. Select the objects and click on the proper button.
Matching width/height

Press the button to match the width of the selected objects. After pressing the button the dropdown list containing two options \((\text{match to the object's width}} \text{ and match to the maximal width})\) should appear on the screen.

The first option is to make the object as wide as the selected object:

![Figure 38. Selection of an object](image)

The second option is to make all objects as wide as the object with the maximal width.
The button allows to match the height of the selected objects.

You can rank the objects by clicking on this button. The following parameters can be set up for the placement of the objects:

- *Gap* — the distance between the objects in pixels;
- *Place*:
  - Horizontally;
  - Vertically;
- *Objects order*

The objects are placed by dragging. The window with settings is shown on the figure below:
After pressing the Place button the objects will be ranked in accordance with the settings.

### 3.3.3. Standard Menu

The Standard menu is shown on the figure below:

![Standard Menu](image)

Figure 42. The *Standard* Menu

The *Standard* menu includes the following items:

1. *Buttons*
2. *Images*
3. *Layouts*
4. *Text objects*
5. *State objects* (*checkboxes and radiobuttons*)
6. *Compound*
7. Windows
8. Menu

3.3.4. Extended menu

The Extended menu is shown on the figure below:

![Extended menu](image)

Figure 43. The Extended menu.

It consists of the following items:

1. Google map;
2. Collapsible panel;
3. Clock;
4. Audioplayer;
5. Checkbox list;
6. Tray icon;
7. Connector object;
8. Timer.

3.3.5. The Shapes menu

The Shapes menu is shown on the figure below:

![Shapes menu](image)

Figure 44. The Shapes menu.

This menu comprises the following items:

1) Simple:
   1. Square
   2. Circle
3. Rectangle
4. Losange
5. Rhombus

2) Extended:
6. Polygon

3.3.6. Vaadin menu

![Vaadin menu](image)

Figure 45. The *Vaadin* menu

The *Vaadin* menu includes the following items:

1. Buttons
2. Layout
3. Text
4. Date
5. Compound
6. Window

3.3.7. Tools and Frames menu

The *Tools and Frames* menu is shown on the figure below:

![Tools and Frames menu](image)

Figure 46. The *Tools and Frames* menu

It includes the following items:

1. Area settings;
2. Frames settings;
3. Tools
4. Zoom
If a tool is available, its icon is highlighted. The description of the interfaces of all tools is given in section Tools.

### 3.3.7.1. The display of actions

![Hide/display actions on the edit area](image)

Each action is designated by a blue arrow directed from the object defining the event towards the object of the action. The button allows to display and to hide actions on the edit area. Hiding the actions may be useful when, for instance, the objects are connected by a great number of actions and their visualization makes difficulties in the perception of the interface. If it is necessary to define the actions the objects are connected by, it is sufficient to display the actions again.

### 3.3.7.2. Objects view customization

![Display the borders](image)

This button allows to display the borders of the area occupied by the object. The borders are marked by the black dotted line. The function may be useful when working with objects whose border is implicit.

![Figure 47. The borders are not displayed](image)

![Figure 48. The borders are displayed](image)
3.3.8. The Help Menu

The Help menu is shown on the figure below:

![Help Menu Diagram]

Figure 49. The Help Menu

It includes the following items:

1. User's Manual;
2. Tip of the day;
3. GUI Machine site;
4. ALEE Software site;
5. About the programs;
6. Send us an e-mail;
7. GUI Machine forum
3.4. Edit Area

The Edit Area is the main working area in which prototypes are created. It consists of the following elements:

- the edit area;
- the toolbar;
- the page manager
3.4.1 Edit Area

Single objects, interface elements and prototypes can be located on the edit area. The edit area can be resized if necessary.

**Edit Area Navigation**

The Edit Area can be navigated:

- with the help of the horizontal and the vertical scrollbars;
- by moving the mouse with the wheel pressed;
- by pressing the keys *Page Up* and *Page Down* for shifting from screen to screen up and down;
- by pressing the keys *Page Up* and *Page Down* together with *Ctrl* for moving from screen to screen to the left and to the right;
- by pressing the keys *End* and *Home* together with *Ctrl* for moving to the right lower corner and the left upper corner;
- by pressing the icons ➡️, up или ➡️ in the left upper corner;
- with the help of the Hand tool. Select the item Application Settings in the File menu or press *Ctrl+S*. Deselect the checkbox *Navigation scroll with middle mouse button*.

![Navigation settings](Figure 51. Navigation settings)
The **Hand** tool will appear right after clicking on the mouse wheel. The navigation with the Hand tool is also available on pressing **Space+ PgUp/PgDn**. This type of navigation may be very useful when working with prototypes of great size.

### 3.4.1.1. Rulers

The rulers provide for the exact positioning and the size of the objects. They are located along the upper and the left borders of the edit area. The tick marks on the ruler show the position of the cursor when moving. The shifting of the grid origin allows to begin measuring from a definite point on the object. The size of the objects is measured in pixels by default. The tick marks are located over one tick in five. To change the settings of the ruler select the item **File → Application settings** or press **Ctrl+S**:

![Ruler settings](image.png)

*Figure 52. Ruler settings*
3.4.1.2. The grid

The grid provides for the exact and symmetrical positioning of objects. It consists of nonprintable symbols. It can be changed and hidden.

The size of the grid is changed when changing the ruler settings. It is possible to change the grid spacing and the area width. To change the grid size select the item **Tools and Frames → Area Settings**

3.4.1.3. Guidelines

The guidelines as well as the grid allow to position the objects more exactly.

The guidelines are displayed as nonprintable blue lines on the edit area. The guidelines can be added, moved, hidden and deleted. They can also be fixed lest they moved by mistake. The distance between the guidelines can be set ad libitum. You can set any distance between the guidelines. When moving any guideline is highlighted with red.

The guidelines work in the following way:

➢ The selected objects are snapped to the guidelines when moving for 8 pixels from them.

To disable snapping the objects to guidelines select **Tools and Frames → Area Settings** and click the icon ![snap to guidelines]

---

Adding guidelines

Guidelines can be added in the following way:

➔ Double-click the horizontal ruler to add a vertical guideline and the vertical rule to add a horizontal guideline.
➔ Press the right mouse button when the cursor is on the vertical or on the horizontal ruler and move the cursor to the edit area in order to create the guidelines.
➔ Press the left mouse button when the cursor is on the crossing of the rulers and move the cursor to the edit area to create guidelines.

---

Moving guidelines

To move a guideline mouse it over (the appearance of the cursor must change) and move it to any place on the edit area.
It is also possible to create two intersecting guidelines. Mouse the intersection over and move it to any place on the edit area.

**Hiding guidelines**

To hide the guidelines select **Tools and Frames → Area Settings and click the icon** (show guidelines). To display the guidelines click this button again.

**Deleting guidelines**

To delete a guideline drag it to the area where the ruler is located. To delete all guidelines select the item **Tools And Frames → Area Settings and click on the icon** (delete guidelines). You should see the following window appear:

![Guidelines removal window](image)

Figure 53. Deleting guidelines

Select the guidelines to delete in the dropdown list. The following options are available:

- All;
- Horizontal only;
- Vertical only.

Select the necessary option and press **OK**.

**Locking the guidelines**

To lock the guidelines select the item **Tools and Frames → Area Settings** and click on the icon (lock the guidelines). This will make the moving of the guidelines impossible. If you need to move the guidelines, click on this icon again.

**3.4.2. Settings for prototype preview**

The set of tools for prototype preview is given on the figure below:
For the detailed description of the tools will be given in further items.

3.4.2.1. Settings for the edit area

The edit area can also be customized from the main menu.

3.4.2.2. Print settings

File → Print pages

In this item you can change such settings as the type of the printer, the number of copies, the print range.

File → Show pages
This item allows to display the borders of the printable pages and areas. The borders of pages are marked by red lines.

![Figure 56. The outline of printable pages](image)

After selecting this option you should see the following window appear:
In this window you may change the following settings:

- **Size**;
- **Feeding**;
- **Orientation**;
- **Margin**.

After changing the settings press **OK**.

### 3.4.2.3. Settings for the appearance of the edit area

Clicking this icon you can switch the display of the background on/off. When the background is switched off the edit area looks as shown on the figure below:
This function may be useful for the more demonstrative display of transparent and nontransparent objects.

Figure 58. The edit area without background

Figure 59. The white background

Figure 60. Without background

**Tool frame → Area settings → Pages background color**

Clicking on this button you can change the necessary color of the page background.

**Tools and Frames → Area Settings → Show large grid**

The size of the grid increases when pressing this button.

### 3.4.2.4. Settings for guidelines

**Tools and Frames → Area settings → Snap to guidelines**

When this option is selected the objects are not snapped to guidelines serving as orienting points.
3.4.2.5. Navigation settings

The order of the objects on the edit area is shown by icons located on the right and at the bottom. (Fig. 50).

By this figure it's possible to define that the polygons are situated in the upper part of the edit area; between them there is a window and to the left of it there is a menu; in the lowest part of the area there is a list.

This function is useful for object search of the objects are situated far from each other.

3.4.3. Page manager

When a prototype includes multiple interfaces, it is more convenient to create its parts on separate pages

![Page manager](image)

Figure 61. Page manager

The page manager allows to:

- create new pages;
➔ remove pages;
➔ rename pages;
➔ to browse the list of pages;
➔ to switch between the pages.

There are several ways to create a new page:

➔ to make a right-button click on the tab of any page and select the item **Create new page**;
➔ to press **Ctrl+N**;
➔ to select the item **Edit → New page** in the main menu;
➔ to make left-button double-click on the empty area located on the right of the tabs of the pages.

There are several ways to delete pages:

➔ to click the pages tab and select the item **Delete page**;
➔ to select the item **Edit → Delete page** in the main menu;
➔ to press **Ctrl+W**.

There are several ways to rename pages:

➔ to double-click on the tab of the page to be renamed;
➔ to make a right-button click on the tab of the page and select the item **Rename page**;
➔ to select the item **Edit → Rename page** in the main menu;
➔ to press **Ctrl+F2**.

There are three ways to switch between the panels:

➔ to make a left-button click on the tab of the page. If the tab is located beyond the zone of vision, press the buttons ← → or use scrolling by the mouse wheel;
➔ to select the necessary page from the list;
➔ to select the tab of the page and press the arrow buttons.

---

**Cache flush**

To flush the cache select the item **File → Program settings** and press the button **Clear cache** in the window that will open.

💡 Cache flush is recommended when you notice that some of the objects went out of the layout and were modified.
4. Tools

The functions of the following tools are described in this section:

➔ Components;
➔ Object properties;
➔ Layers;
➔ History;
➔ Templates

4.1. Components

This is the basic tool used for the creation of prototypes. GUI Machine comprises four sets of components: Standard, Extended, Shapes and Vaadin.
Components are represented by leaf nodes of the tree. They are united in groups in accordance with their function forming terminal nodes. You can change the way of displaying components by a right-button click at any place.
To display the components panel select **Tools and Frames**→ **Frame Settings** and click the icon **Components** (Fig. 67). The tool is switched on by default.

This tool is designed for adding components on the edit area.

There are two ways to add a component on the edit area:

- by a double-click
- by dragging it with the mouse

All the components are described in table below.
Table 2. Components

<table>
<thead>
<tr>
<th>Icon</th>
<th>Component</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Standard" /></td>
<td>Standard</td>
<td></td>
</tr>
<tr>
<td><img src="image" alt="Buttons" /></td>
<td><strong>Buttons</strong></td>
<td></td>
</tr>
<tr>
<td><img src="image" alt="Button" /></td>
<td>Button</td>
<td>A user interface element providing the user a simple way to trigger an event.</td>
</tr>
<tr>
<td><img src="image" alt="Toggle button" /></td>
<td>Toggle button</td>
<td>A button with the additional possibility to toggle a state. It has two states, select and deselected.</td>
</tr>
<tr>
<td><img src="image" alt="Images" /></td>
<td><strong>Images</strong></td>
<td></td>
</tr>
<tr>
<td><img src="image" alt="Image" /></td>
<td>Image</td>
<td>Allows to insert images in the prototype.</td>
</tr>
<tr>
<td><img src="image" alt="Separator" /></td>
<td>Separator</td>
<td>A widget allowing to divide the parts of the interface.</td>
</tr>
<tr>
<td><img src="image" alt="Layout" /></td>
<td><strong>Layouts</strong></td>
<td></td>
</tr>
<tr>
<td><img src="image" alt="Dynamic layout" /></td>
<td>Dynamic layout</td>
<td>This is the wireframe of dynamic interfaces. It allows to divide the area into cells and arrange the objects inside. Each cells can be resized. The objects in the layout are resized when resizing the interface.</td>
</tr>
<tr>
<td><img src="image" alt="Static layout" /></td>
<td>Static layout</td>
<td>Allows to arrange objects inside without lining. It fits automatically to the size of the objects it contains. The objects in the layout are not resized when viewing the prototype.</td>
</tr>
<tr>
<td><img src="image" alt="Tabbed pane" /></td>
<td>Tabbed pane</td>
<td>Allows multiple elements to be contained within a single window using tabs as navigational widgets for switching between these elements.</td>
</tr>
<tr>
<td></td>
<td>Panel</td>
<td>Allows to divide the interface into logical parts as well as to arrange control elements.</td>
</tr>
<tr>
<td>---</td>
<td>---</td>
<td>---</td>
</tr>
<tr>
<td></td>
<td>Split pane</td>
<td>A panel with a draggable divider (also called splitter) between two components. It allows the user to change the size of the components dynamically.</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th></th>
<th>Text</th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Text label</td>
<td>A standard widget used for displaying text on the screen.</td>
</tr>
<tr>
<td></td>
<td>Text field</td>
<td>An interface element allowing the user to enter text information.</td>
</tr>
<tr>
<td></td>
<td>Password field</td>
<td>A standard widget used for entering passwords. Password field allows to create a field, similar to a text field, that users can type into. This field however causes everything show up as asterisks (*) so onlookers cannot see what is being typed.</td>
</tr>
<tr>
<td></td>
<td>Text area</td>
<td>An interface element inside which texts are type and element/</td>
</tr>
<tr>
<td></td>
<td>HTML-editor</td>
<td>A text area designed for work with HTML-texts.</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th></th>
<th>Condition</th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Checkbox</td>
<td>Permits the user to make multiple selections from a number of options or to have the user answer yes (checked) or no (not checked) on a simple yes/no question.</td>
</tr>
<tr>
<td></td>
<td>Radiobutton</td>
<td>Allows to select one of the predefined set of options.</td>
</tr>
</tbody>
</table>
## Compound

<table>
<thead>
<tr>
<th>Widget</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Placeholder</td>
<td>A widget standing for another interface element.</td>
</tr>
<tr>
<td>Progress bar</td>
<td>A widget used to convey the progress of a task, such as a download or file transfer.</td>
</tr>
<tr>
<td>Combobox</td>
<td>It is a combination of a dropdown list and a single-line textbox allowing the user to either type a value directly into the control or choose from the list of existing options.</td>
</tr>
<tr>
<td>Scroll bar</td>
<td>A widget with which continuous text, pictures or anything else can be scrolled, i.e., viewed even if it does not fit into the space in a display, window or viewport.</td>
</tr>
<tr>
<td>Slider</td>
<td>A widget with which a user may set a value by moving an indicator, usually in a horizontal fashion.</td>
</tr>
<tr>
<td>Spinner</td>
<td>A graphical widget, typically oriented vertically, with which a user can adjust the value in the adjoining textbox by either clicking on an up and down arrow or by holding the arrows down thus making the value increase or decrease.</td>
</tr>
<tr>
<td>List</td>
<td>Allows the user to select one or more items from a list contained within a static, multiple line text box. The user clicks on an item to select it. Multiple selections are made by clicking on items in combination with the Shift key or with the Control key.</td>
</tr>
<tr>
<td>Table</td>
<td>Allows to create tables.</td>
</tr>
</tbody>
</table>
## Tree

A tree is a data-structure that emulating hierarchical tree structure with linking nodes. Internal nodes can be open by clicking (+) and (-).

## Windows

<table>
<thead>
<tr>
<th>Window</th>
<th>Allows to create windows.</th>
</tr>
</thead>
</table>

## Menu

<table>
<thead>
<tr>
<th>Menu bar</th>
<th>Allows to create menu bar. A menu bar is a region of a screen or application interface where dropdown menus are displayed.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Pop-up menu (context menu)</td>
<td>A menu appearing upon user interaction, typically upon a right-button click. Usually it has a limited number of choices related to the selected object.</td>
</tr>
</tbody>
</table>

## Extended

## Images

<table>
<thead>
<tr>
<th>Google map</th>
<th>Allows to add a Google map</th>
</tr>
</thead>
</table>

## Layout

<table>
<thead>
<tr>
<th>Collapsible pane</th>
<th>A panel which can store content in a compact space. User can hide or reveal the content of the panel by clicking on its tab.</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>GUI Machine User’s Manual</strong></td>
<td></td>
</tr>
<tr>
<td>-----------------------------</td>
<td></td>
</tr>
<tr>
<td><strong>Clocks</strong></td>
<td>Allows to add to the interface clocks of different types</td>
</tr>
<tr>
<td><strong>Media</strong></td>
<td></td>
</tr>
<tr>
<td><img src="image" alt="Image of Media" /></td>
<td>Audio player</td>
</tr>
<tr>
<td><strong>Compound</strong></td>
<td></td>
</tr>
<tr>
<td><img src="image" alt="Image of Compound" /></td>
<td>Checkbox list</td>
</tr>
<tr>
<td><strong>System</strong></td>
<td></td>
</tr>
<tr>
<td><img src="image" alt="Image of System" /></td>
<td>Tray icon</td>
</tr>
<tr>
<td>Connector object</td>
<td>An interface element allowing to establish connection with other prototypes or applications via system sockets</td>
</tr>
<tr>
<td><strong>Actions</strong></td>
<td></td>
</tr>
<tr>
<td><img src="image" alt="Image of Actions" /></td>
<td>Timer</td>
</tr>
<tr>
<td><strong>Shapes</strong></td>
<td></td>
</tr>
<tr>
<td><img src="image" alt="Image of Shapes" /></td>
<td>Simple</td>
</tr>
<tr>
<td>Shape</td>
<td>Description</td>
</tr>
<tr>
<td>---------</td>
<td>----------------------------------</td>
</tr>
<tr>
<td>Circle</td>
<td>Allows to add a circle.</td>
</tr>
<tr>
<td>Oval</td>
<td>Allows to add an oval.</td>
</tr>
<tr>
<td>Square</td>
<td>Allows to add a square.</td>
</tr>
<tr>
<td>Rectangle</td>
<td>Allows to add a rectangle.</td>
</tr>
<tr>
<td>Rhombus</td>
<td>Allows to add a rhombus.</td>
</tr>
</tbody>
</table>

### Extended

<table>
<thead>
<tr>
<th>Shape</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Polygon</td>
<td>Allows to add a polygon.</td>
</tr>
</tbody>
</table>

---

**Vaadin Components**

### Date

<table>
<thead>
<tr>
<th>Component</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Date field</td>
<td>A widget allowing the user to enter the date either by typing it or by choosing it from the calendar in the dropdown menu.</td>
</tr>
<tr>
<td>Calendar</td>
<td>A widget displaying the calendar and allowing to select the date.</td>
</tr>
</tbody>
</table>
Note. The Vaadin set of components also includes components similar to those included in the standard set. As their functions are the same, their detailed description is not included in this table.

4.2. Object Properties

With the help of this tool you can select different settings for object thus modifying the look of interface elements. When an object on the edit area is selected, its properties are displayed in the special window.

The number of properties depends upon the type of the object. Each object has *unique* (i.e. pertinent to a certain type of objects) and *repeated* (pertinent to objects of different types)

All object properties can be divided into the following groups:

- properties for concrete types of objects;
- general properties characteristic for all objects;
- editor properties, i.e. those influencing the display of the object on the edit area but not in the prototypes

It is possible to modify the properties of the objects set by default. Some of the properties can be modified when editing. Some of the properties cannot be changed (for instance, object type or object ID). It is possible to modify the properties of several objects when selecting all of them.

4.2.1. The Description of Object Properties

4.2.1.1. Standard Properties

Standard properties are those which can be attributed to all objects. They are described in the table below:

*Table 3. Standard object properties*

<table>
<thead>
<tr>
<th>Icon</th>
<th>Property</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Tool tip text</td>
<td>By changing this property you can change the text in the tooltip appearing when hovering the cursor on the object.</td>
</tr>
<tr>
<td></td>
<td>Cursor</td>
<td>This property allows to select a cursor for the object from a predefined set.</td>
</tr>
<tr>
<td>Property</td>
<td>Description</td>
<td></td>
</tr>
<tr>
<td>-------------------</td>
<td>------------------------------------------------------------------------------</td>
<td></td>
</tr>
<tr>
<td>Visible</td>
<td>By changing this property you can make the object visible/invisible on the edit area.</td>
<td></td>
</tr>
<tr>
<td>Opacity</td>
<td>Allows to change the opacity of the object in the range from 0 (transparent) to 1 (absolutely opaque).</td>
<td></td>
</tr>
<tr>
<td>Scroll bars</td>
<td>Allows to switch the display of scrollbars on/off.</td>
<td></td>
</tr>
<tr>
<td>Horizontal scroll</td>
<td>This property works only when the scrollbars are on. It allows to set up the display of the horizontal scroll bar. The following options can be selected from the dropdown list: - <em>Always show</em>; - <em>Show when needed</em>; - <em>Never show</em>.</td>
<td></td>
</tr>
<tr>
<td>Vertical scroll</td>
<td>This property works only when the scrollbars are on. It allows to set up the display of the vertical scroll bar. The following options can be selected from the dropdown list: - <em>Always show</em>; - <em>Show when needed</em>; - <em>Never show</em>.</td>
<td></td>
</tr>
</tbody>
</table>
### 4.2.1.2 Properties for Editor

*Table 4. Properties for Editor*

<table>
<thead>
<tr>
<th>Icon</th>
<th>Property</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Object type icon" /></td>
<td>Object type</td>
<td>Displays the type of the object. This property cannot be edited.</td>
</tr>
<tr>
<td><img src="image" alt="Object ID icon" /></td>
<td>Object ID</td>
<td>Displays the identical number of the object. Cannot be edited.</td>
</tr>
<tr>
<td><img src="image" alt="Minimal size icon" /></td>
<td>Minimal size</td>
<td>Allows to set the minimal size of the object. This property is editable but not for all objects. The minimal size of the object cannot exceed the default size.</td>
</tr>
<tr>
<td><img src="image" alt="Name icon" /></td>
<td>Name</td>
<td>Displays the name of the object.</td>
</tr>
<tr>
<td><img src="image" alt="Resizable left-right icon" /></td>
<td>Resizable left-right</td>
<td>Allows/prohibits the changing of the object width</td>
</tr>
<tr>
<td><img src="image" alt="Resizable up-down icon" /></td>
<td>Resizable up-down</td>
<td>Allows/prohibits the changing of the object height.</td>
</tr>
<tr>
<td><img src="image" alt="Movable icon" /></td>
<td>Movable</td>
<td>Allows/prohibits to move the object</td>
</tr>
</tbody>
</table>

### 4.2.1.2. Properties for buttons

*Table 5. Properties of buttons*

<table>
<thead>
<tr>
<th>Icon</th>
<th>Property</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Image icon" /></td>
<td>Image</td>
<td>This property allows to select an image for the button.</td>
</tr>
<tr>
<td>Property</td>
<td>Description</td>
<td></td>
</tr>
<tr>
<td>------------------------------</td>
<td>-----------------------------------------------------------------------------</td>
<td></td>
</tr>
<tr>
<td>Selected image</td>
<td>Allows to select the image which will be displayed when the button is selected.</td>
<td></td>
</tr>
<tr>
<td>Rollover image</td>
<td>Allows to select the image which will be displayed when the button is hovered.</td>
<td></td>
</tr>
<tr>
<td>Selected rollover image</td>
<td>Allows to select the image which will be displayed when the button is selected and hovered.</td>
<td></td>
</tr>
<tr>
<td>Pressed image</td>
<td>Allows to select the image which will be displayed when the button is pressed.</td>
<td></td>
</tr>
<tr>
<td>Disabled image</td>
<td>Allows to select the image which will be displayed when the button is disabled.</td>
<td></td>
</tr>
<tr>
<td>Selected disabled image</td>
<td>Allows to select the image which will be displayed when the button is selected and disabled.</td>
<td></td>
</tr>
<tr>
<td>Text</td>
<td>This property allows to select the text for the button.</td>
<td></td>
</tr>
<tr>
<td>Selected text</td>
<td>Allows to enter the text which will be displayed when the button is selected.</td>
<td></td>
</tr>
<tr>
<td>Disabled text</td>
<td>Allows to enter the text which will be displayed when the button is hovered.</td>
<td></td>
</tr>
<tr>
<td>Selected disabled text</td>
<td>Allows to enter the text which will be displayed when the button is selected and hovered.</td>
<td></td>
</tr>
<tr>
<td>Rollover text</td>
<td>Allows to enter the text which will be displayed when the button is pressed.</td>
<td></td>
</tr>
<tr>
<td>Pressed text</td>
<td>Allows to enter the text which will be displayed when the button is disabled.</td>
<td></td>
</tr>
<tr>
<td>Mnemonic</td>
<td>Allows to set a mnemonic for a button</td>
<td></td>
</tr>
<tr>
<td>Gap</td>
<td>Allows to set a gap between the image and the text.</td>
<td></td>
</tr>
<tr>
<td>Text shift</td>
<td>Allows to set the size of the lacunes in the text.</td>
<td></td>
</tr>
<tr>
<td>Horizontal alignment</td>
<td>Allows to align the content horizontally. Three options are available: Center, Left, Right.</td>
<td></td>
</tr>
<tr>
<td>Vertical alignment</td>
<td>Allows to align the content vertically. Three options are available: Center, Left, Right.</td>
<td></td>
</tr>
</tbody>
</table>
Horizontal text position relative to the image: Allows to position the text horizontally relative to the image. Three options are available: Center, Left, Right.

Vertical text position relative to the image: Allows to position the text vertically relative to the image. Three options are available: Center, Left, Right.

Font color: Allows to change the font color

Font: Allows to change the type and the size of the font

Enable: Allows to enable/disable the object

Decorated: Enables/disables the decoration of the object

*Mnemonic is an underlined character in the text inside the button. It indicates which key to press to activate a command or navigate to a component.

4.2.1.3. Properties for images

Table 6. Properties for images

<table>
<thead>
<tr>
<th>Icon</th>
<th>Property</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image_icon.png" alt="Image" /></td>
<td>Image</td>
<td>Allows to add images from the file system or from the previously used images. The images can also be found by Google search engine.</td>
</tr>
<tr>
<td><img src="orientation_icon.png" alt="Orientation" /></td>
<td>Orientation</td>
<td>Allows to position the image:</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• by the size of the image</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• by the size of the object;</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• as a background image.</td>
</tr>
<tr>
<td><img src="scale_icon.png" alt="Scale" /></td>
<td>Scale</td>
<td>Horizontal and vertical image scaling</td>
</tr>
<tr>
<td><img src="rotation_angle_icon.png" alt="Rotation angle" /></td>
<td>Rotation angle</td>
<td>Allows to set the image angle (0° - 399°)</td>
</tr>
<tr>
<td><img src="horizontal_alignment_icon.png" alt="Horizontal alignment" /></td>
<td>Horizontal alignment</td>
<td>Allows to align the content horizontally. Three options are available: Center, Left, Right.</td>
</tr>
<tr>
<td><img src="vertical_alignment_icon.png" alt="Vertical alignment" /></td>
<td>Vertical alignment</td>
<td>Allows to align the content vertically. Three options are available: Center, Left, Right.</td>
</tr>
</tbody>
</table>
### 4.2.1.4. Properties for separators

**Table 7. Properties for separators**

<table>
<thead>
<tr>
<th>Icon</th>
<th>Property</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>![Orientation icon]</td>
<td><strong>Orientation</strong></td>
<td>Allows to position the separator horizontally or vertically</td>
</tr>
<tr>
<td>![Background color icon]</td>
<td><strong>Background color</strong></td>
<td>Allows to select the background color for separators.</td>
</tr>
<tr>
<td>![Unlock icon]</td>
<td><strong>Unlocked</strong></td>
<td>Allows to lock/unlock the object</td>
</tr>
</tbody>
</table>

### 4.2.1.5. Properties for layouts

**Table 8. Properties for layouts**

<table>
<thead>
<tr>
<th>Icon</th>
<th>Property</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>![Linked objects icon]</td>
<td><strong>Linked objects</strong></td>
<td>This property shows the number of objects linked to the layout and cannot be edited.</td>
</tr>
<tr>
<td>![Columns/rows icon]</td>
<td><strong>Columns/rows</strong></td>
<td>This property shows the number of columns and rows in the layout and cannot be edited.</td>
</tr>
<tr>
<td>![Border color icon]</td>
<td><strong>Border color</strong></td>
<td>Allows to change the border color.</td>
</tr>
<tr>
<td>![Background color icon]</td>
<td><strong>Background color</strong></td>
<td>Allow to set the background color.</td>
</tr>
<tr>
<td>![Update content dynamically icon]</td>
<td><strong>Update content dynamically</strong></td>
<td>Allows to display the layout object when it is used in another interface (by means of an action or a placeholder)</td>
</tr>
<tr>
<td>![Show borders icon]</td>
<td><strong>Show borders</strong></td>
<td>Allows to display the border of a dynamic layout when previewing.</td>
</tr>
<tr>
<td>![Border width icon]</td>
<td><strong>Border width</strong></td>
<td>Allows to set up the width of borders</td>
</tr>
</tbody>
</table>
### 4.2.1.6. Properties for panels

**Table 9. Properties for panels**

<table>
<thead>
<tr>
<th>Icon</th>
<th>Property</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>📄</td>
<td>Show cell borders over the background</td>
<td>Allows to display the borders of the cells.</td>
</tr>
<tr>
<td>📄</td>
<td>Spacing</td>
<td>Allows to fix the spacing between the cells of the layout</td>
</tr>
<tr>
<td>📄</td>
<td>Border type</td>
<td>Allows to select the type of the border. There are 7 border types:</td>
</tr>
<tr>
<td>📄</td>
<td>☐ Border type</td>
<td>• Empty;</td>
</tr>
<tr>
<td>📄</td>
<td>☐ Border type</td>
<td>• Line;</td>
</tr>
<tr>
<td>📄</td>
<td>☐ Border type</td>
<td>• Rounded;</td>
</tr>
<tr>
<td>📄</td>
<td>☐ Border type</td>
<td>• Lowered bevel;</td>
</tr>
<tr>
<td>📄</td>
<td>☐ Border type</td>
<td>• Raised bevel;</td>
</tr>
<tr>
<td>📄</td>
<td>☐ Border type</td>
<td>• Lowered etched;</td>
</tr>
<tr>
<td>📄</td>
<td>☐ Border type</td>
<td>• Raised etched.</td>
</tr>
<tr>
<td>📄</td>
<td>Border width</td>
<td>Allows to set the border width.</td>
</tr>
<tr>
<td>📄</td>
<td>Border color</td>
<td>Allows to select the border color.</td>
</tr>
<tr>
<td>📄</td>
<td>Border dark side color</td>
<td>Allows to select the color for the dark side of the border.</td>
</tr>
<tr>
<td>📄</td>
<td>Border light side color</td>
<td>Allows to select the color for the light side of the border.</td>
</tr>
<tr>
<td>📄</td>
<td>Border header</td>
<td>Allows to set the header for the border of the panel.</td>
</tr>
</tbody>
</table>
4.2.1.7. Properties for split panels

Table 10. Properties for split panels.

<table>
<thead>
<tr>
<th>Icon</th>
<th>Property</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Divider location</td>
<td>Shows the location of the divider on the split panel.</td>
</tr>
<tr>
<td></td>
<td>Divider size</td>
<td>Allows to change the size of the divider.</td>
</tr>
</tbody>
</table>

4.2.1.8. Properties for tabbed panels

Table 11. Properties for tabbed panels

<table>
<thead>
<tr>
<th>Icon</th>
<th>Property</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Tabs properties</td>
<td>Displays the number of tabs. Allows to add and edit tabs.</td>
</tr>
<tr>
<td></td>
<td>Selected tab</td>
<td>Displays the selected tab and allows to change tabs.</td>
</tr>
<tr>
<td></td>
<td>Tabs position</td>
<td>Allows to change the position of the tabs.</td>
</tr>
</tbody>
</table>
### 4.2.1.9. Properties for text fields and areas

**Table 12. Properties for text fields and areas**

<table>
<thead>
<tr>
<th>Icon</th>
<th>Property</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>📜</td>
<td>Text</td>
<td>Allows to enter and edit the text</td>
</tr>
<tr>
<td>📜</td>
<td>Text margin</td>
<td>Allows to set the text margin</td>
</tr>
<tr>
<td>🌐</td>
<td>Link</td>
<td>Allows to add a link:</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• to a website (e.g., <a href="http://www.google.com">http://www.google.com</a>);</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• to a local resource (e.g., C:);</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• to an e-mail address (e.g., <a href="mailto:support@alee.ru">mailto:support@alee.ru</a>);</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• to a FTP resource (e.g., <a href="">ftp://files.alee.ru</a>).</td>
</tr>
<tr>
<td>📜</td>
<td>Empty field text</td>
<td>Allows to enter the default text displayed in empty text forms.</td>
</tr>
<tr>
<td>🆔</td>
<td>Empty field font</td>
<td>Allows to select the font for the empty field text.</td>
</tr>
<tr>
<td>📜</td>
<td>Empty field font color</td>
<td>Allows to select the color of the font for the empty field text.</td>
</tr>
<tr>
<td>🌐</td>
<td>Background color</td>
<td>Allows to select background color.</td>
</tr>
<tr>
<td>🆔</td>
<td>Font</td>
<td>Allows to select the style and the size of the font</td>
</tr>
<tr>
<td>🆔</td>
<td>Font color</td>
<td>Allows to select the font color</td>
</tr>
<tr>
<td>Icon</td>
<td>Property</td>
<td>Description</td>
</tr>
<tr>
<td>------</td>
<td>----------------------------------------</td>
<td>--------------------------------------------------</td>
</tr>
<tr>
<td></td>
<td>Empty field text horizontal alignment</td>
<td>Allows to align the empty field text horizontally.</td>
</tr>
<tr>
<td></td>
<td>Empty field text vertical alignment</td>
<td>Allows to align the empty field text vertically.</td>
</tr>
<tr>
<td></td>
<td>Masking character</td>
<td>Allows to select the masking character for password fields.</td>
</tr>
<tr>
<td></td>
<td>Line break</td>
<td>Allows/prohibits the line break.</td>
</tr>
<tr>
<td></td>
<td>Wordwrap</td>
<td>Allows/prohibits the wordwrap.</td>
</tr>
<tr>
<td></td>
<td>Content type</td>
<td>Allows to change the way of displaying the content (plain text or HTML).</td>
</tr>
<tr>
<td></td>
<td>Editable</td>
<td>Makes the text available for editing when selected.</td>
</tr>
</tbody>
</table>

### 4.2.1.10. Properties for the placeholder

*Table 13. Properties for the placeholder*

<table>
<thead>
<tr>
<th>Icon</th>
<th>Property</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td><strong>Properties for the placeholder</strong></td>
<td></td>
</tr>
<tr>
<td></td>
<td>Object to be replaced</td>
<td>Allows to select an object to be replaced by the placeholder.</td>
</tr>
</tbody>
</table>
### 4.2.1.11. Properties for the progress bar

Table 14. Properties for the progress bar

<table>
<thead>
<tr>
<th>Icon</th>
<th>Property</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>![Image]</td>
<td>Orientation</td>
<td>Allows to select the bar position (horizontal or vertical).</td>
</tr>
<tr>
<td>![Image]</td>
<td>Indeterminate</td>
<td>The way of visualizing used in situations where the extent of the task is unknown or the progress of the task cannot be determined in a way that could be expressed as a percentage.</td>
</tr>
<tr>
<td>![Image]</td>
<td>Show values</td>
<td>Allows to display the scale.</td>
</tr>
</tbody>
</table>

### 4.2.1.12. Properties for lists

Table 15. Properties for lists

<table>
<thead>
<tr>
<th>Icon</th>
<th>Property</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>![Image]</td>
<td>List settings</td>
<td>Allows to fix the type and the number of elements in the list.</td>
</tr>
<tr>
<td>![Image]</td>
<td>Row height</td>
<td>Allows to set the height of the rows</td>
</tr>
<tr>
<td>![Image]</td>
<td>Indices of selected elements</td>
<td>Displays images for selected list elements.</td>
</tr>
<tr>
<td>![Image]</td>
<td>Orientation</td>
<td>Allows to change orientation for the elements of the list.</td>
</tr>
</tbody>
</table>
Visible range

Allows to fix the visible range of list elements.

Selected element

Displays the selected element. Allows to select the element to be displayed in the field.

Selection foreground

Allows to choose the color for the font of the selected list elements

Selection background

Allows to choose the background for the selected list elements

### 4.2.1.13. Properties for the spinner

*Table 16. Properties for the spinner*

<table>
<thead>
<tr>
<th>Icon</th>
<th>Property</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Current value" /></td>
<td>Current value</td>
<td>Allows to adjust the current value of the spinner.</td>
</tr>
<tr>
<td><img src="image" alt="Value type" /></td>
<td>Value type</td>
<td>Allows to select the type of the value (<em>Number</em> or <em>Date</em>)</td>
</tr>
</tbody>
</table>

### 4.2.1.14. Properties for the slider

*Table 17. Properties for the slider*

<table>
<thead>
<tr>
<th>Icon</th>
<th>Property</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Small division" /></td>
<td>Small division</td>
<td>Adjusts the size of small scale divisions</td>
</tr>
<tr>
<td><img src="image" alt="Coarse division" /></td>
<td>Coarse division</td>
<td>Sets the size of coarse scale divisions</td>
</tr>
</tbody>
</table>
Show values

Description:
Switches on/off the display of divisions value.

Show ticks

Description:
Allows to display the small and coarse divisions of the scale with intervals equal to the sizes of small and coarse divisions respectively.

Snap slider to divisions

Description:
Snaps the slider to the divisions of the scale.

### 4.2.1.15. Properties for the scrollbar

<table>
<thead>
<tr>
<th>Icon</th>
<th>Property</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>📋</td>
<td>Orientation</td>
<td>Allows to configure the orientation of the scrollbar <em>(horizontally or vertically)</em>.</td>
</tr>
<tr>
<td>📋</td>
<td>Small division</td>
<td>Sets the size of small scale divisions</td>
</tr>
<tr>
<td>📋</td>
<td>Coarse division</td>
<td>Sets the size of coarse scale divisions</td>
</tr>
<tr>
<td>📋</td>
<td>Show values</td>
<td>Switches on/off the display of divisions value</td>
</tr>
<tr>
<td>📋</td>
<td>Show ticks</td>
<td>Allows to display the small and coarse divisions of the scale with intervals equal to the sizes of small and coarse divisions respectively.</td>
</tr>
</tbody>
</table>
Snap slider to divisions

Snaps the slider to the divisions of the scale.

Minimal value

Allows to set the minimal value of the interval

Maximal value

Allows to set the maximal value of the interval

Current value

Allows to set the current value

Visible range

Allows to select the region which is visible when viewing the slider.

<table>
<thead>
<tr>
<th>Icon</th>
<th>Property</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Snap slider to divisions</td>
<td>Snaps the slider to the divisions of the scale.</td>
</tr>
<tr>
<td></td>
<td>Minimal value</td>
<td>Allows to set the minimal value of the interval</td>
</tr>
<tr>
<td></td>
<td>Maximal value</td>
<td>Allows to set the maximal value of the interval</td>
</tr>
<tr>
<td></td>
<td>Current value</td>
<td>Allows to set the current value</td>
</tr>
<tr>
<td></td>
<td>Visible range</td>
<td>Allows to select the region which is visible when viewing the slider.</td>
</tr>
</tbody>
</table>

4.2.1.16. Properties for the tree

Table 19. Settings for trees

<table>
<thead>
<tr>
<th>Icon</th>
<th>Property</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Properties for trees</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Tree settings</td>
<td>Allows to modify the structure of the tree and add new elements.</td>
</tr>
</tbody>
</table>
|      | Tree selection mode | Allows to choose one of the three possible selection modes for the elements of the tree:  
|      | Show tree root  | Allows to display the root of the tree                                       |
4.2.1.17. Properties for tables

Table 20. Properties for tables

<table>
<thead>
<tr>
<th>Icon</th>
<th>Property</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Table settings</td>
<td>Displays the number of columns and rows in the table. Allows to edit them.</td>
</tr>
<tr>
<td></td>
<td>Table resize mode</td>
<td>Allows to resize the table.</td>
</tr>
<tr>
<td></td>
<td>Columns reordering allowed</td>
<td>Allows to reorder the columns when viewing the table.</td>
</tr>
<tr>
<td></td>
<td>Selection type</td>
<td>Allows to choose the elements of the table (rows, cells, columns) to be selected</td>
</tr>
<tr>
<td></td>
<td>Selection foreground</td>
<td>Allows to choose the color for the selected elements of the table</td>
</tr>
<tr>
<td></td>
<td>Selection background</td>
<td>Allows to choose the background color for the selected elements of the table</td>
</tr>
<tr>
<td></td>
<td>Show header</td>
<td>Allows to display/hide the header of the table</td>
</tr>
<tr>
<td></td>
<td>Font</td>
<td>Allows to select the style and the size of the font</td>
</tr>
<tr>
<td></td>
<td>Font color</td>
<td>Allows to select the font color</td>
</tr>
<tr>
<td></td>
<td>Background color</td>
<td>Allows to select background color.</td>
</tr>
</tbody>
</table>
### 4.2.1.18. Properties for windows

**Table 21. Properties for windows**

<table>
<thead>
<tr>
<th>Icon</th>
<th>Property</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>![icon]</td>
<td>Window menu bar</td>
<td>Allows to select the menu bar for the window,</td>
</tr>
<tr>
<td>![icon]</td>
<td>Window style</td>
<td>Allows to select the design style for the window. The styles of the following operating systems can be selected: Windows XP, Ubuntu, Windows Vista, Gnome, Mac OS, Windows, Mac OS Grey.</td>
</tr>
<tr>
<td>![icon]</td>
<td>Header style</td>
<td>Allows to select the design for the window header in the style of one of the following browsers: Пустой, Internet Explorer 8, Firefox 3.6, Opera 10, Safari 5.</td>
</tr>
<tr>
<td>![icon]</td>
<td>Dialog window</td>
<td>Displays the window as a dialog window</td>
</tr>
<tr>
<td>![icon]</td>
<td>Modal window</td>
<td>Allows to create a modal window (A modal window is a child window that requires users to interact with it before they can return to operating the parent application, thus preventing the workflow on the application main window. Modal windows are commonly used in GUI systems to command user awareness and to display emergency states. On the Web, they are often used to show images in detail)</td>
</tr>
<tr>
<td>![icon]</td>
<td>Parent window</td>
<td>Allows to select the parent window for the given window.</td>
</tr>
</tbody>
</table>
On top of all windows | Allows to display the window atop all other windows.
---|---
Allow closing window | Allows to enable/disable the closing of the window*
Resizable | Allows to change the size of the window
Pack width | Allows to close the window automatically on focus loss
Pack height | Allows to shrink the window by height when viewing
Pack width | Allows to shrink the window by width when viewing
Font | Allows to select the style and the size of the font
Font color | Allows to select the font color
Background color | Allows to select background color.

*If this property is disabled, the window can be closed by pressing **Shift + F4** or by stopping the preview of all interfaces in the main menu.

### 4.2.1.19. Properties for menus

**Table 22. Properties for menus**

<table>
<thead>
<tr>
<th>Icon</th>
<th>Property</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Menu settings</td>
<td>Displays the number of menu items and launches the menu editor.</td>
</tr>
</tbody>
</table>
### Pop-up menu settings
Displays the number of pop-up menu items and launches the menu editor.

### Font
Allows to select the style and the size of the font.

### Font color
Allows to select the font color.

### Background color
Allows to select background color.

## 4.2.1.20. Properties for Google maps

*Table 23. Properties for Google maps.*

<table>
<thead>
<tr>
<th>Icon</th>
<th>Property</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Map location keywords icon" /></td>
<td>Map location keywords</td>
<td>Allows to mark with keywords the selected geographical points on the map.</td>
</tr>
<tr>
<td><img src="image" alt="Map type icon" /></td>
<td>Map type</td>
<td>Allows to select the type of the map (road map, satellite map, physical relief map, satellite and road map hybrid)</td>
</tr>
<tr>
<td><img src="image" alt="Map size icon" /></td>
<td>Map size</td>
<td>Allows to set the size of the map in pixels.</td>
</tr>
<tr>
<td><img src="image" alt="Map zoom icon" /></td>
<td>Map zoom</td>
<td>Allows to increase the map according to the given scale.</td>
</tr>
<tr>
<td><img src="image" alt="Map image format icon" /></td>
<td>Map image format</td>
<td>Allows to select the format for the map: PNG8, PNG32, JPEG, compressed JPEG image, GIF image.</td>
</tr>
<tr>
<td><img src="image" alt="Orientation icon" /></td>
<td>Orientation</td>
<td>Allows to fit the image:</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• to the image size;</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• to the object size</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• as a background image.</td>
</tr>
<tr>
<td><img src="image" alt="Scale icon" /></td>
<td>Scale</td>
<td>Horizontal and vertical scaling of the image.</td>
</tr>
<tr>
<td><img src="image" alt="Rotation angle icon" /></td>
<td>Rotation angle</td>
<td>Allows to set the rotation angle for the image (from 0 up to 359°)</td>
</tr>
</tbody>
</table>
### Horizontal alignment

Allows to align the object horizontally. There are three possible options: *Left*, *Right*, *Center*.

<table>
<thead>
<tr>
<th>Icon</th>
<th>Vertical alignment</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Allows to align the object vertically. There are three possible options: <em>Left</em>, <em>Right</em>, <em>Center</em>.</td>
</tr>
</tbody>
</table>

### 4.2.1.21. Properties for collapsible panes

*Table 24. Properties for collapsible panes*

<table>
<thead>
<tr>
<th>Icon</th>
<th>Property</th>
<th>Description</th>
</tr>
</thead>
</table>
|      | **Style** | Allows to select the design of the collapsible pane:  
  • *Dropdown list*
  • *Tree;*
  • *Separator;*
  • *Plain.* |
|      | **Placement** | Allows to select the position of the pane. There are four possible options: *Top, Right, Left, Bottom.* |
|      | **Emphasized** | Allows to emphasize the header of the pane. |
|      | **Expandable** | Switches on/off the ability of the pane to collapse/expand. |
|      | **Collapsed** | Allows to collapse the pane. |
|      | **Image** | Allows to select the image which will be displayed in the panel header. |
|      | **Text** | Allows to enter the text which will be displayed in the panel header. |
|      | **Font** | Allows to select the style and the size of the font |
### 4.2.1.22. Properties for clocks

Table 25. Properties for clocks

<table>
<thead>
<tr>
<th>Icon</th>
<th>Property</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>![Font color]</td>
<td><strong>Font color</strong></td>
<td>Allows to select the font color</td>
</tr>
<tr>
<td>![Background color]</td>
<td><strong>Background color</strong></td>
<td>Allows to select background color.</td>
</tr>
</tbody>
</table>

#### Properties for clocks

<table>
<thead>
<tr>
<th>Icon</th>
<th>Property</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>![Time pattern]</td>
<td><strong>Time pattern</strong></td>
<td>Allows to set the pattern for displaying time and date. By default the time is displayed according to the pattern hh:mm:ss. The following patterns are also possible:</td>
</tr>
<tr>
<td>![Clock type]</td>
<td><strong>Clock type</strong></td>
<td>Allows to select the type of the clock (clock, stop watch, timer).</td>
</tr>
<tr>
<td>![Time to complete]</td>
<td><strong>Time to complete</strong></td>
<td>Allows to set the time interval for the timer in millisec</td>
</tr>
<tr>
<td>![Font]</td>
<td><strong>Font</strong></td>
<td>Allows to select the style and the size of the font</td>
</tr>
<tr>
<td>![Font color]</td>
<td><strong>Font color</strong></td>
<td>Allows to select the font color</td>
</tr>
</tbody>
</table>

© 2007-2011 ALEE Software
### 4.2.1.23. Properties for the audio player

**Table 26. Properties for the audio player**

<table>
<thead>
<tr>
<th>Icon</th>
<th>Property</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>🎵</td>
<td>Audio resource</td>
<td>Allows to select an audio file to be played. The location of the file should be typed manually in the text field. Now it is possible to play mp3 files only.</td>
</tr>
</tbody>
</table>

### 4.2.1.24. Properties for the connector object

**Table 27. Properties for the connector object**

<table>
<thead>
<tr>
<th>Icon</th>
<th>Property</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>📠</td>
<td>Port number</td>
<td>Allows to set the port number for connection</td>
</tr>
</tbody>
</table>
### 4.2.1.25. Properties for shapes

**Table 28. Properties for shapes**

<table>
<thead>
<tr>
<th>Icon</th>
<th>Property</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Moves window icon" /></td>
<td>Moves window</td>
<td>Allows to change the position of the window</td>
</tr>
<tr>
<td><img src="image" alt="Resizes window icon" /></td>
<td>Resizes window</td>
<td>Allows to resize the window when holding the figure</td>
</tr>
<tr>
<td><img src="image" alt="Corner rounding icon" /></td>
<td>Corner rounding</td>
<td>Allows to round the corners of the rectangles. The property is coded by two values separated from each other by a column. For circular rounding enter two equal values. For elliptical rounding enter two different values. If the first number is greater than the second, the ellipse will be extended horizontally, otherwise – vertically.</td>
</tr>
<tr>
<td><img src="image" alt="Polygon corners icon" /></td>
<td>Polygon corners</td>
<td>Displays the number of corners in a polygon.</td>
</tr>
<tr>
<td><img src="image" alt="Snap points to sides icon" /></td>
<td>Snap points to sides</td>
<td>Allows to enable/disable snapping points to the sides of a polygon.</td>
</tr>
</tbody>
</table>

### 4.2.1.26. Properties for data fields and calendars

**Table 29. Properties for data fields and calendars**

<table>
<thead>
<tr>
<th>Icon</th>
<th>Property</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Selected date icon" /></td>
<td>Selected date</td>
<td>Displays the date and allows to select the date in the calendar. The selected date is highlighted with blue.</td>
</tr>
<tr>
<td><img src="image" alt="Displayed date icon" /></td>
<td>Displayed date</td>
<td>Displays the date when the calendar is previewed.</td>
</tr>
</tbody>
</table>

Time pattern

Allows to select a pattern of date and time display:

<table>
<thead>
<tr>
<th>Date format</th>
<th>Result</th>
</tr>
</thead>
<tbody>
<tr>
<td>yyyy.MM.dd G 'of' HH:mm:ss z</td>
<td>2011-04-04 10:46:46 MST</td>
</tr>
<tr>
<td>EEE, MMM d, &quot;yy</td>
<td>Mon, Apr 4, '11</td>
</tr>
<tr>
<td>h:mm a</td>
<td>10:46 AM</td>
</tr>
<tr>
<td>hh 'o'clock' a, zz</td>
<td>10 o'clock AM, MST</td>
</tr>
<tr>
<td>K:mm a, z</td>
<td>10:46 AM, MST</td>
</tr>
<tr>
<td>yyyy.MM.ddG GGG h:mm:ssz</td>
<td>02011-Apr-04 AD 10:46 AM</td>
</tr>
<tr>
<td>EEE, d MMM yyyy HH:mm:ss Z</td>
<td>Mon, 4 Apr 2011 10:46:46 +0400</td>
</tr>
<tr>
<td>yyMMddHHmmssZ</td>
<td>119404104646+0400</td>
</tr>
</tbody>
</table>

Opaque

Allows to change the degree of the opacity of the object

### 4.2.1.27 Properties for the tray icon

Table 30. Properties for the tray icon.

<table>
<thead>
<tr>
<th>Icon</th>
<th>Property</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image.png" alt="Image" /></td>
<td>Image</td>
<td>Allows to add image to the tray icon.</td>
</tr>
</tbody>
</table>
4.2.2. Auxiliary tools

Some object properties are set with the help of auxiliary tools. These tools are described below.

4.2.2.1. HTML/Text editor

**HTML/Text editor** is designed for typing, editing and formatting text. The interface of this tool is simple and user familiar.

To launch **HTML/Текстового редактора** you need to:

- open the properties object;
- select **Text** property;
- click on the button located right near this property

![Object properties](image)

**Figure 68. Launching the HTML-editor**

💡 If you do no need to work with HTML text, there is no need to launch the **HTML/Text editor**. It is sufficient to type the text in the text field.

The main window of the tool includes 3 tabs:

- **HTML-editor**
- **HTML-code**
- **Text editor**
HTML-editor

**HTML-editor** allows to create and edit texts in HTML-format. You do not need to know HTML-language to work with the editor. The workspace of the editor includes:

- the toolbar;
- the workspace where the text is entered.

The toolbar consists of **the upper** and **the lower** line.

**The upper line of tools** includes the instruments for:

- working with clipboard copying and pasting;
- inserting different objects (images, tables, symbols, links)
- cancelling/repeating the operations;
- copying text formatting;
- creating and editing tables;
- zooming;
- drawing figures.

![Figure 69. HTML editor.](image-url)
The lower line of tools is designed for formatting text and is used for setting the following characteristics of the text:

- header type;
- font;
- font size;
- text style (bold, italic, underlined);
- subscript/superscript mode;
- horizontal text alignment;
- the size of indents;
- numbered/bullet list;
- font color;
- background color.

After creating the text in the **HTML editor** you can modify them right on the edit area. Double click on the object to edit the text contained in it. On figure 70 a text-label with HTML content is shown). The text on the edit area will look as it is shown on the figure below:

![Figure 70. Modifying text on edit area.](image)
The font of the text can be changed with the help of the standard key shortcuts:

- Ctrl+I — italic;
- Ctrl+B — bold;
- Ctrl+U — underlined

**HTML-code**

After editing the text in the HTML-editor you can view the automatically generating HTML-code in the appropriate tab.

![HTML-code screenshot](image)

**Figure 71. HTML-code**

You can edit the HTML code manually. Switch to the **HTML-code** tab and enter the necessary text. In the **HTML-editor** tab you can see how the texts looks like after the changes you made.
Text editor

If you want to create a text without HTML formatting, you can use the Text editor tools. Texts previously edited in the HTML-editor will be displayed as plain text:

![Image of text editor](image)

Figure 72. Text editor tab.

Texts created in this tab will not be HTML-formated.

When editing text in the text editors do not wrap the words by pressing *Enter*. If the text was wrapped, all lines will be merged in one.

4.2.2.2. Image selection tool

This tool allows to select an image:

- from the file system;
- from the previously used images;
➢ from screenshots
➢ from the set of icons;
➢ from the images found by Google.

To open the image selection tool enter the object properties, select **Image** and press the button located on the right of the text. You can also open this tool by double-clicking on the image on the edit area. Then the following window with three text should open:

➢ **For file** — a standard system window:

![Choose Image Window](image)

**Figure 73. Selecting an image from the file system**

➢ **From used before** — the window displaying the thumbnails of previously used images;
By selecting/deselecting the checkbox **Draw alpha as background** you can enable/disable the displaying of the alpha layer.

To change the size of the thumbnails enter the necessary parameters in the field **Thumbnail size**.

The checkbox **Show image size** enables/disables the displaying of the borders of images.

It contains the following information:

- **Name**
- **Image type**
- **Image size**

➢ **From screenshots** — this window contains the screenshots made with the help of the screenshot making tool:
Figure 75. Selecting an image from the screenshots

➢ **From icons collection** — the window containing a set of icons available with the application:

Figure 76. Selecting an image from the icon collection
➢ Search in Google — the window allowing to select an image from those found by Google:

![Image search window](image.png)

Figure 77. Selecting an image from those found by Google

Different parameters for the search can be set up:

**Image settings:**
1. Image file format (PNG, JPEG, GIF, any)
2. Grayscale or Colored image (or any)
3. The main color of the image (black, gray, white, red, green, blue, orange, brown, pink, purple, teal, yellow)
4. Type of image content (Faces, photos, clipart, lineart, any)
5. Image size (Icon, small, medium, large, extra large, huge, any)

**Filter settings:**
1. Site address for search;
2. Filtration level (high, moderate, none)
3. Image license type (Any, Public Domain, Attribution, Share-alike, Noncommercial, No Derivate Works)
Preview settings:

1. Draw alpha as background
2. Preview size (in pixels)

4.2.2.3. Editing tabs

The editor for tabbed panels allows to:

- add and remove tabs by pressing the buttons  and ;
- change the position of the tabs by pressing the buttons  and ;
- add images to the headers of the tabs by pressing the button ;
- remove images from the headers of the tabs by pressing the button ;
- lock/unlock the tabs by pressing the button ;
- rename the tabs by double-clicking on them.

The text of the tab headers can be changed without launching the editor. Double-click the header to edit the text contained in it.

Figure 78. Editor for tab panels
4.2.2.4. Table editor

The editor for tables allows to:

➢ add and remove rows and columns by pressing the buttons 
and 
;
➢ to change the position of the elements of the table by pressing the buttons , , and ,
➢ add images to the cells of the table by pressing the button ;
➢ remove images from the cells by pressing the button ;
➢ rename the columns of the table by double-clicking on them;
➢ permit/prohibit the editing of the cells by selecting the appropriate checkbox;
➢ select one of the following 6 tab types:

◦ Text;
◦ Integer;
◦ Floating;
◦ Date;
◦ Boolean;
◦ Icon

Figure 79. Table editor
4.2.2.5. Tree editor

The tree editor allows to:

- add and remove tree elements by pressing the buttons and ;
- change the level of elements by pressing the buttons and ;
- move elements up and down by pressing the buttons and ;
- add images to the tree elements by pressing the button ;
- remove images by pressing the button ;
- rename the tree elements by double-clicking on them.

![The tree editor](image)

Figure 80. The tree editor

4.2.2.6. List editor

The list editor allows to:

- add and remove elements by pressing the buttons and ;
- to change the position of the elements by pressing buttons and ;
- to change the background of the elements of the list by pressing the buttons and ;
- rename elements of the list by double-clicking on them;
- to select images by double-clicking on the **Icon** field
➢ to set up the position of the text (horizontal or vertical) in relation to the image.

![List values editor](image)

Figure 81. The list editor

### 4.2.2.7. Checkbox editor

The checkbox editor has the same functions as the list editor. It also allows to

- *lock / unlock* list elements by selecting the checkbox enabled;
- make the checkboxes selected/deselected by default by editing the appropriate columns.
4.2.2.8. Editing popup menus

The popup menu editor allows to

- add and remove the items by pressing the buttons and ;
- change the order of items by pressing the buttons and ;
- select a type of items from the following options:
  - separator;
  - text;
  - checkbox;
  - radiobutton;
- make an item selected by default by setting the flag Selected (for checkboxes and radiobuttons only);
- enable/disable the menu items (the Enabled column);
- set mnemonics for menu items by pressing Alt+mnemonic;
- create submenus for menu items;
- change the text of menu items using the HTML-editor;
- add images to menu items (the Icon column);
- create keyboard shortcuts for menu items (the Hotkey column).
Pressing the hot keys during the preview is equal to the selection of the items.

You can see the menu with the settings as shown above on the figure below:

![Figure 83. Pop-up menu editor](image)

Figure 83. Pop-up menu editor

If you need to edit the text of the menu items (without changing their format), you can do it on the edit area by double-clicking them:
You can edit the item even if it contains HTML-text:

![Figure 85. Editing pop-up menu items](image)

You can add a submenu to any of the items by hovering it and opening the context menu by a right-button click:

![Figure 86. Editing HTML-text in popup menu items](image)

You can add a submenu to any of the items by hovering it and opening the context menu by a right-button click:

![Figure 87. Adding submenus to popup menu items](image)
4.2.2.9. Menu editor

The menu editor allows to:

➢ add and remove the items by pressing the buttons  and ;
➢ change the order of items by pressing the buttons  and , ;
➢ enable/disable the menu items (the Enabled column);
➢ set mnemonics for menu items by pressing Alt+mnemonic
➢ select popup menus for each menu items
➢ edit the text of menu items (including HTML texts)

If you need to edit the text of the items (including HTML texts) you can do it right on the edit area by double-clicking them:

The connection between the menu item and its popup menu is marked by gray arrows:
The menu with popup menus looks as it is shown on the figure below:

![Menu with popup menus](image)

**Figure 90. The connection between the menu and the popup menu**

A popup menu can be removed from the item in the main menu. To remove the pop up menu approach the mouse cursor to the item, press the right button and select the item *Remove popup menu...* in the context menu.
To underline the mnemonic symbols press the *Alt* when viewing. To select the menu item press the key with the underlined symbol.

If the text of the item was created in the HTML editor, the mnemonic will not be underlined.

### 4.2.2.10. Selecting in a cursor

In the cursor selection window you can choose a cursor from:
- standard system cursors;
- sets of cursors.

**The standard cursors** have the design set up in the operating system in the settings for mouse cursors. In the sets of cursors you can select a cursor in one of the following styles:
- Blue;
- Yellow;
➢ Hand;
➢ Static;
➢ Arrows;
➢ Cross;
➢ Tools;
➢ Windows Aero.

💡 It is recommended to use standard cursors matching the style of the operating system in general. This will allow you to create realistic prototypes.

Figure 93. Selecting a cursor
4.3. Layers

The Layers are the main tool used for creating interfaces. This tool is indispensable for editing interfaces.

The Layers tool provides information about the location of the objects, their hierarchy and actions connecting them.

With the help of this tool you can show and hide objects, remove them, add and edit actions.

Thus the object located on the layer with the greatest number is displayed above all others and the object with the smallest number is located below all others.

To open the Layers tool select the menu item Tools and Frames → Frames Settings → Layers.

The hierarchy of objects is represented as a tree structure:

![Figure 94. Layers. The tree of objects](image)

© 2007-2011 ALEE Software
The tree of objects is created on the basis of connections between them. Actions and events are also included in the tree structure. The tree allows to visualize the structure of the interface. The tree-like structure is used for the representation of interfaces the most often. The fashion of the representation of the objects can be changed. Approach the cursor to the **Layers** panel and press the right mouse button:

![Context menu for the layers](image)

**Figure 95. Context menu for the layers**

Select the item **Show objects list**. The content of the panel will be displayed as shown below:

![The list of objects](image)

**Figure 96. The list of objects**
The names of the objects as well as those of the actions can be edited. To rename an object or an action select it and press \textbf{F2}. Objects in the tree can be renamed by triple click upon them.

### The context menu

Make a right-button click on the tree to access to the context menu (рис.95)

The context menu allows to select to select the main preview object, sort objects, show and hide actions.

To select the main preview object in the project select the item \textbf{Set as main preview object in the context menu}.

To show/hide actions select the item \textbf{Show actions}.

Settings for sorting:

- Sorting order:
  - \textit{Ascending} sorting;
  - \textit{Descending} sorting;
  - \textit{Do not sort}.

- Property for sorting:
  - \textit{Sort by object layer};
  - \textit{Sort by object name} ;
  - \textit{Sort by the text property};
  - \textit{Sort by object type}.

### 4.3.1. Tools for working with layers

Tools for working with layers are located in the menu \textbf{Edit--Change object layers}. The description of the tools is given in the table below.

\textit{Table 31. Tools for working with layers}

<table>
<thead>
<tr>
<th>Icon</th>
<th>Tool</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image1" alt="icon" /></td>
<td>Bring forward</td>
<td>Raises the object one layer up</td>
</tr>
<tr>
<td><img src="image2" alt="icon" /></td>
<td>Bring back</td>
<td>Moves the object one layer down</td>
</tr>
<tr>
<td><img src="image3" alt="icon" /></td>
<td>Move object to the top layer</td>
<td>Moves the selected object to the top layer</td>
</tr>
<tr>
<td>Button</td>
<td>Function</td>
<td>Description</td>
</tr>
<tr>
<td>--------</td>
<td>----------</td>
<td>-------------</td>
</tr>
<tr>
<td><img src="image" alt="Icon" /></td>
<td>Move object to the bottom layer</td>
<td>Moves the selected object to the bottom layer</td>
</tr>
<tr>
<td><img src="image" alt="Icon" /></td>
<td>Hide layer</td>
<td>Hides the selected layer</td>
</tr>
<tr>
<td><img src="image" alt="Icon" /></td>
<td>Show layer</td>
<td>Shows the selected layer</td>
</tr>
<tr>
<td><img src="image" alt="Icon" /></td>
<td>Select all layers</td>
<td>Selects all visible layers</td>
</tr>
<tr>
<td><img src="image" alt="Icon" /></td>
<td>Deselect all layers</td>
<td>Allows to undo the selection</td>
</tr>
</tbody>
</table>
4.4. History

The tool History allows to return to any of the previous stages of the project.

Every time you make an operation in the project a new entry is added to the History. If you add, for instance, a new element to the project and then change its properties, these operations will be listed in the History. If you select one of the entries, all the changes brought to the project after the appropriate operation will be abolished. You can continue the work from the selected project state.

![History window]

Figure 97. The history of the project

The number of entries saved in the History can be limited by the user. When this number is exceeded, the entries are deleted.

New entries are added to the end of the list. Thus the entries concerning the earlier operations can be found in the beginning of the list, the entries about the newer ones – in the end.

For each page of the project a separate History list is created. If the number of the entries in the list is too great, the size of the project file will increase. If there is no need to save the information about all entries, the History list can be cleared.
➢ open the context menu by a right-button click on the **History** panel;

![History context menu](image)

Figure 98. History context menu

➢ select the item **Clear page history**.

The **History** list for the selected page will be cleared.

To clear all history lists select the item **Clear all history**

The entries in the history can be marked with color. The colors can be changed:

![Colored history entries](image)

Figure 99. Colored history entries

The context menu also allows to display the date and the time for each operation in the project. Select the items **Show event date** and **Show event time**.

---

**Return to the previous state**

There are two ways of returning to the previous state of the project:

➢ Pressing **Ctrl+Z**. Each time the keys are pressed a change in the project is abolished.
➢ A left-button click on the entry related to the state to which you would like to return.

<table>
<thead>
<tr>
<th>The repeated of abolished operations</th>
</tr>
</thead>
</table>

If you made an error when abolishing an operation, there are two ways of correcting it:

➢ Pressing **Ctrl+Shift+Z.** Each time you press the keys the abolished operation is repeated.
➢ A left-button click on the entry related to the stage to which you would like to return.

**NB:** If a new operation is made after canceling several operations, the entries related to the canceled operations will be deleted. The return to the canceled operations will become impossible.
4.5. Templates

A template is a ready-made mockup of a frequently used object. Using templates can make the creation of prototypes easier and faster, especially when different parts of the prototype contain similar objects.

Templates can be created for all types of objects.

![Figure 100. User templates](image)

The templates are represented as a tree-like structure. You can create and delete folders for keeping templates.

<table>
<thead>
<tr>
<th>Icon</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Create new template" /></td>
<td>Create new template Allows to create a new template</td>
</tr>
<tr>
<td><img src="image" alt="Remove template" /></td>
<td>Remove template Removes the selected template</td>
</tr>
<tr>
<td><img src="image" alt="Create new folder" /></td>
<td>Create new folder Creates a new folder</td>
</tr>
<tr>
<td><img src="image" alt="Remove folder" /></td>
<td>Remove folder Removes the selected folder</td>
</tr>
</tbody>
</table>
To create a template do the following:

➔ add an object to the edit area;
➔ modify the object;
➔ press the button **Create new template**
➔ enter the name of the template.

To use a template in the project drag it to the edit area.

### 4.5.1. Importing/exporting templates

The templates created by the user are stored in the folder `/templates/data` located inside **GUI Machine** install folder. Each template is stored as a separate XML file. The images for each template are stored in separate folders. Thus the templates are not tied to a concrete project; they can be used in any project you like.

To import the templates to another computer or to another folder just copy the the folder **templates** to the new GUI Machine install folder.
5. Working in GUI Machine

5.1. General information

General recommendations

To insert one object into another drag it to the necessary location. The insert area will be highlighted with blue:

![Inserting an object](image)

Figure 101. Inserting an object

The following objects cannot be inserted into other ones:

- Standard and Vaadin windows;
- Popup menus;
- Timers;
- Audio players;
- Tray icons.
The following objects can contain other objects:

- Windows
- Dynamic layouts
- Static layouts
- Panels
- Tabbed panels
- Split panels
- Collapsible panels

Use the templates. It can help you to save time and make prototyping easier.

Use **hot keys**. In some situations it is the best way to access to necessary operations.

Use context menus. It also allows to perform some operations faster.

Use **placeholders**. Add a placeholder to the edit area. Insert it to the location where you are going to place an object. There are two ways to select an object to be replaced by the placeholder:

- Click on the property **Object to be replaced** and select an object in the tree;
- Select the item **Object to be replaced** in the context menu of the placeholder. The item towards which the cursor is pointed is highlighted:

![Figure 102. Selecting an object to be replaced by the placeholder](image-url)
During the preview the substitute object is displayed on the place of the placeholder. The usage of placeholders can prevent you from creating too complicated cumbersome interfaces. If you wish to unlink the placeholder from the object it substitute, select the item **Unlink the replaced object** in the context menu.

It is recommended to create different interfaces on different pages. This will prevent you from overloading pages. If the page is overloaded with interface elements and actions, the navigation may become more complicated.

---

### Getting started

Choose the working mode (section 2.4. Launch).

When making a prototype of an application it is convenient to create the large interface parts first and the work through details.

To begin prototyping add a window to the edit area first. Select is properties. Select the header style and resize it if necessary. When selecting the style of the window check into consideration the size and the resolution of the screen.

💡 When adding new objects it is recommended to name them in accordance with their function. This will allow you to navigate a large project more easily.

---

### Static and dynamic layouts

Layout is the framework for prototypes. All interfaces are designed on the basis of layouts.

There are **three ways of prototyping** in **GUI Machine**:

- prototyping with *static layouts*;
- prototyping with *dynamic layouts*;
- mixed prototyping.

Prototyping with *static layouts* is rather simple and fast, but prototypes created in such a way are not interactive.
Static layouts can be used when the goal of prototyping is to create a set of screenshots. When such a prototype is previewed, the objects remain immobile. Static layouts cannot be lined, so it is recommended to use guidelines and operations of aligning.

Prototypes created with *dynamic layouts* are lively and realistic. This way of prototyping is recommended if you want to simulate the work of a real program.

In *mixed prototyping* both static and dynamic layouts are used. This is the optimal way of creating prototypes but it requires a certain experience of working with GUI Machine.
5.2. Working with static layouts

A static layout can contain several objects without ruling. To create an interface enter the necessary objects into the layout. If an object having a great size is inserted, the layout will be increased automatically.

If the objects in the layout are not displayed correctly, rearrange them with the help of the Layers tool. The possibility of adding actions to static layouts is limited. A possible solution is inserting a dynamic layout into a static one.

![Figure 103. An interface based on a static layout](image)

![Figure 104. A static layout interface being previewed](image)
5.3. Working with dynamic layouts

5.3.1. Ruling

Ruling allows to divide a dynamic layout into several rectangle cells.

Select the layout and press the button ➢

- If you press the button under the layout a column is added;
- If you press the button on the right of the layout a row is added.

To remove a column or a row press the button ➥.

**NB:** when removing a row or a columns all objects inside it are also removed.

![Figure 105. Ruling a layout](image)

5.3.2. The size of cells

The size of each cell can be set by moving the slider:

- in *pixels* (✕);
- fit to the optimal size of an object inserted into a layout cell— *Preferred size* (✕);
- in percentage of the free layout space.

The size indicated in *pixels* is fixed. Changes brought to the layout do not cause resizing such zones.

The size of the zone set as *preferred size* becomes equal to that of the object inserted into the appropriate cell. The optimal size is the size of the object at which its image, text, etc. are seen. The size of the zone indicated during the editing of the layout will be ignored. The size of the zone set as the preferred size can be changed when clearing cells or inserting a new object.
The size indicate in percentage of the free layout space, can be changed dynamically. The free space of the layout is that left after selecting the zones whose size is indicated in pixels or set as the preferred size. It is these zones that are changed when changing the size of the layout. The size of at least one zone in the layout should be indicated in the percentage of free space.

To indicate the size of a zone in percentage of free layout space press the button \( \text{\textbullet} \). The button above the last zone with the size in percentage of free layout space is blocked: \( \text{\textbullet} \).

To set the size as the preferred size press \( \text{\textbullet} \), to set the size in pixels press \( \text{\textbullet} \).

**Example:**

On figure 106 it is obvious that:

- zone 1 the size of which is indicated in pixels, was not resized during the preview;
- zone 2, whose size is set as preferred size, was diminished and fitted to the size of the object inserted in it;
- zones 3 and 4, whose sized is indicated in percentage of the free layout space increased 25 and 75% of the space occupied by zone 2.

The layout contains one column whose size ought to have been indicated in percentage of free layout space and cannot be changed. That is why the button above it is blocked.

From the layout on the right part of figure 106 it is obvious that after decreasing the size of the layout:

- zones 1 and 2 were not modified;
- zones 3 and 4 were diminished 25% и 75% of the diminished part of the layout.
For the exact setting of layout rows and columns select the items **Set px columns height** and **Set px rows width** in the context menu.

Enter the necessary size in pixels. The cells will be resized in accordance with the value you entered:

![Figure 107. Identification of rows and columns](image)

It is possible to enter the values of the size for each Nth zone divided by a comma. If you enter “10,20” the size of the zones with odd number will become equal to 10 pixels and the size of the zones with even numbers will be equal to 20 pixels.

![Figure 108. Setting the size of layout zones](image)

The size of the zones can also be set up manually (by moving the slider).
5.3.3. Inserting an object in several cells

There are two ways of inserting objects in several layout cells:

➢ stretch the object over the cells:

![Figure 109. Stretching the object over two layout cells](image)

➢ open the context menu and select the item **Add object by cells**. Select the cells keeping the left mouse button pressed and insert the object:

![Figure 110. Inserting an object in two layout cells](image)

If the object exceeds the size of the layout, it will be decreased to the size of a layout cell. If it is impossible to decrease the object, it will not be inserting and you should see the following tooltip:

![Figure 111. An error occurring at inserting an object into a dynamic layout](image)
5.3.4. The background of cells

In **GUI Machine** it is possible to change the background of the selected layout cells:

- open the context menu of the layout;
- select the item **Change cells background**;

![Change selected cell background](image1)

Figure 112. Changing the background of layout cells

- select the cells keeping the left button of the mouse pressed:

![Selecting cells to change the background](image2)

Figure 113. Selecting cells to change the background

Release the mouse button. The following window should open:
There are the following options for the background of the cells:

- Color;
- Gradient;
- Image;
- Alpha layer

Select the necessary tab. When selecting the tab **Color** the cells will be painted with solid color:
When selecting the item **Gradient** the selected cells will be flooded with gradient:

![Gradient](image)

**Figure 116. Gradient**

You can select the type of the gradient (linear or radial) in the dropdown menu **Type**. In the dropdown menu **Repeat** you can define whether the gradient will repeat. The range of the gradient can be set up by moving the slider located above the dropdown menu. Set the necessary parameters and press **Save** button. To use an image as the background for the layout cells select the tab **Image**.

![Image](image)

**Figure 117. Selecting an image**
Select the way of placing the image in the **Image placement** dropdown list:

- As background image;
- Fit to full object size
- Fit to image size:

![Image placement options](image.png)

Figure 118. Selecting the image placement

If you select the option **As background image**, the image will be set as background. It will be multiply repeated without resizing.

![Background settings](background_settings.png)

Figure 119. Placing an image as a background image

If you select the option **Fit to image size**, the image will be located in the center of the selected cells without resizing:
If you select the option **Fit to full object size** the image will be extended to the size of the selected cells:

![Figure 120. Fitting to image size](image1)

If you select the option **Alpha layer**, the selected cells will be filled with alpha layer. The alpha layer is a sequence of squares used for marking transparent areas. Enter the size of a square side in pixels in the field **Square size**. The default size of a square size is 10 pixels. You can also select the color for the squared.

![Figure 121. Fitting to full image size](image2)
After changing the settings press the **Save** button:

![Background settings](image)

Figure 122. Settings for the alpha-layer
Example.
On the figure below you can see a layout in which backgrounds with all possible settings are used:

Figure 123. Settings for the background of cells
When previewed the layout shown on figure 123 looks as it is shown on the figure below:

![Example of a GUI layout](image)

**Figure 124. Previewing a layout**

To change the background of a single cell:

- select the cell and click on it to open the context menu;
- select the item **Change selected cell background**:

![Context menu options](image)

**Figure 125. Changing the background of a single cell**

It is possible to put several backgrounds into one layout cell. That is why in the program there are two ways of clearing the background of cells:

- total clearing;
➢ selective clearing.
Total clearing is removing all backgrouns from the cells.
For total clearing:

➢ Select the item **Clear cells background** in the context menu:

![Context menu with Clear cells background option](image)

Figure 126. Clearing the background of cells

➢ press the left mouse button and select the cells to be cleared

After clearing the cells will have the background indicated in **Background color** property.

Selective clearing allows to remove one of the previously set backgrounds:

➢ select the item **Clear cells background** in the context menu. Press the left mouse button and select the cells the background of which you need to clear. Press **Clear** button in the window that should open.

💡 During the selective clearing choose the cells for which the background was cells. The button **Clear** will not be active otherwise.

💡 The property **Background color** does not depend upon the background set by means of the operations described above. If you change the background of all cells with the help of the context menu, the property will remain unchanged.

💡 The background selected in the context menu is displayed above the background indicated in the property **Background color**.
5.4. Recommendations and examples

Avoid situations when the size of a layout cell is equal to the minimal size of the object inserted into it. In the.

If you cannot diminish a layout on the edit area, check the zones whose size is indicated in percentage of the free layout space. It is more than likely that one of these zones reached its minimal size.

If one of the zones whose size is indicated in percentage of the free layout space has reached its minimal size when adding a new cell to the layout, the size of the layout will be increased by 10 pixels.

How to remove table headers

To remove the header of a table disable the property **Scroll bars**. Thus the borders of the table will also be removed.

![Figure 127. A table without header](image)

**Scroll bars**

Be attentive when using scroll bars. On figure 128 you can see the layout with the disabled (on the left) and enabled (on the right) **Scroll bars** property.

If this property is disabled, the layout looks as it is displayed on the edit area when previewed. In the layout with scroll bars enabled the horizontal scroll bar lead to the increasement of the first column whose size was indicates in percentage of the free layout space. Thus the images shifted to the right.
Sometimes it is necessary to prevent from the increasing of layout columns when scrollbars are enabled. If you do not want the column to increase, indicate its size in pixels. If you want the column to increase, indicate its size in percentage of the free layout space.
To avoid the increasing of all layout columns, add an empty column with the minimum size and assign 100% of free space to it.

Figure 128. The influence of scroll bars on the display of the layout
One more way of selecting images

There is one more way to select an image and it faster and more convenient than those described above:

➢ click on an existing image or on an object containing images;
➢ copy the value of the **Image** property ;
➢ insert it into the Image property of the necessary object

How to create a pop-up window

Add a window on the edit area. Disable the property **Decorated** and enable the property **Close on focus loss**. Despite of the fact that it is displayed as a decorated window on the edit area, it will look like a pop up window and will be closed on focus loss when launched.

Example: a pop-up window appears when pressing the button.

![A pop-up window in preview](image)

*NB*: the property **Decorated** can be disabled for standard windows only. With Vaadin windows the operation described above is impossible.
Grouping objects

Objects like radio buttons and toggle buttons can be united in groups. Select the objects you would like to unite and enter the number of the group into the property **Grouping**. During the preview these objects will work as a group. This means that:

- only one object from the group can be in the **selected** state;
- if only one objects in the group is selected the other ones become deselected.

How to create single line and multiline texts

Sometimes it is necessary to make the text in a label single-line or multiline.

If you want to locate the text on several lines, open the **Text** property and select the tab **HTML editor**. HTML-texts are always multiline.

If you want to make multiline text single-line, go to the tab HTML-code and tag it `<nobr></nobr>`

You can use all HTML tags in the tab HTML-code.

![Figure 130. Multiline and single-line texts](image)
Operations with images on the edit area

On images located on the edit area the following operations can be performed:

- increasing or decreasing the size of the object to the size of the image;
- rotating the image around its center.

These operations are performed by pressing the buttons above the image:

![Image buttons](image)

By double-clicking the rotation angle is set as $0^\circ$.

How to set the border for an object/a region

You can use a Panel as a border for a region. Insert the panel into necessary region and disable the property Border header. Select the type, the color and the width for the border in the properties.

How to create a switching

To create a checkbox with switching icons:

- select the image representing the checkbox in the Image property;
- select the image for the selected state of the checkbox in the Selected image property;

The same procedure can be applied to Radiobuttons.
This procedure can be applied to toggle buttons if the property Decorated is disabled.

Copying objects containing actions

To copy the objects with actions related to them, select the objects being event triggers and action targets together and copy them.
If only one object (either event trigger or action target) is selected and copied, the action will not be copied.
Working with polygons

To add a corner press the icon. To remove an angle press Ctrl and click on it. To move the vertex of angle not only on the borders of the object but also inside it disable the property Snap points to sides.

To curving the sides of the polygon disable the property Snap points to sides and move the vertices holding the Shift key.

![Curving the sides of a polygon](image)

How to add a menu to a window

There to ways to add a menu to a window:

- Open the context menu and select the item Choose window menu bar, then click on the menu so it be inserted into the window.
- In the properties of the window select the property Window menu bar and select the menu to be inserted into the window in the tree.

You can also select a submenu for each menu item by the following ways:

- Right-click on the item to which you would like to add a submenu. The context menu will open. Select the item Choose popup for menu in the context menu and then left-click on the necessary submenu.
- Open the Menu editor. In the column Popup menu select the submenu for the item by pressing the button.
A window containing a menu with a submenu is shown on the figure below:

![Figure 133. A window with a menu](image)

To unlink the menu and the window select the item **Unlink window menu bar** in the context menu. To replace the existing menu by another one open the context menu and select the item **Change window menu bar**.
How to create a tailor-made window

In GUI Machine it is possible to create original windows (not only rectangular, but also round, elliptical, etc.)
To create a tailor-made window:
➢ add a window to the edit area;
➢ disable the properties Decorated and Opaque;
➢ select the geometrical configuration for the window in the Shapes menu;
➢ set up the limits within which it will be possible to move the window:

➢ drag the figure on the window.

The window will take the shape of the selected figure when previewed. Other components can also be added to tailor-made windows.
5.5. Operations on the project

Saving the project

To save the project select the item **File → Save project** in the file menu or press **Ctrl+S**.

If you would like to change the location for saving the project or if you did not create project in the beginning of the work, select the item **File → Save project as...** Select the directory in the window that will open.

💡 It is highly recommended to backup all projects you work upon. This can prevent you from data loss.

When a project is saved:

- All the images are saved in the subdirectory */resources* located in the directory of the projects.
- All the screenshots are saved in the subdirectory */screenshots* located in the directory of the project.

The templates are not linked to any project. They are saved in the subdirectory */templates* located in GUI Machine install folder.

Opening a project

To open a project:

- select the item **File → Open project** in the main menu
- select the necessary file;
- press the button **Open**;

To open a demo project:

- select the item **File → Demo projects** in the main menu
- select a project in the list and click on it
If you have made the association of *.gui files with GUI Machine during the installation, they can be opened by double-clicking.

Creating a project

To create a project select the item File → New project or press Ctrl+N. Enter the name of the new project and select the directory for saving it.

💡 The current project will not be saved when creating a new project in the fashion described above. All the changes will be lost. Save the current project before creating a new one.

Project settings

To access to the project settings select the item File → Project settings in the main menu or press Ctrl+Alt+S. The following window should open:
In the tab **Main settings** the following parameters can be edited:

- the name of the project;
- the owner of the project;
- the company of the owner;
- the description of the project.

With the help of the **preview settings** you can manage the work of the prototype during its preview in **GUI Machine Viewer**.

Click on the field **Main preview object** to access to the tree-like structure of project elements. Select the object and press the button **Choose**.
If you do not need to choose the main preview object, deselect all objects by clicking on them while keeping the Ctrl key pressed and then press the button Choose.

To enable the preview of all launches objects in GUI Machine Viewer select the appropriate checkbox.

If you want to preview all the objects of the project in GUI Machine Viewer, select the checkbox Allow to preview all objects.

With the help of the History settings panel it is possible to manage the history records.

If you want to limit the number of records to be stored, select the checkbox Keep limited number of records and enter the value in the text field.

If the checkbox is deselected, the text field will be blocked and the number of history records will not be limited.

The tab Project information is shown on the figure below:
In this tab you can find the following information:

1. The number of pages;
2. The number of preview objects;
3. The number of guidelines;
4. The total number of objects
5. The number of objects of different typers
6. The total number of actions (and the number of multipage actions)
7. The number of events of different types
8. The number of actions of different types
9. The size of the project file
10. The number of images and their total size
11. The number of screenshots and their total size
12. The total size of the project (the used RAM).
Application settings

Select the item **File → Application settings** in the context menu. The following window will open:

![Application settings window](image)

**Figure 138. Application settings**

By clicking on the icons you can select different types of settings:

- **General settings**
- **Visual settings**
- **Search settings**
- **Preview settings**
- **Component settings**
General settings

In this window (fig. 138) you can edit the following parameters:

1. Application language (English/ Russian)
2. Minimum available memory
3. Maximum available memory
4. Settings for saving edited images (Always ask; Always into a separate file; Always into the same file)
5. Setting for autosaving the project
6. Time intervals for autosaving
7. Proxy settings (address, exceptions, login, password).
Visual settings

In this window you can configure the following settings:

1. The position of the tabs of the pages
2. Hiding the tabs when only one page is open
3. Minimal area size (height * width in pixels);
4. Settings for the supplementary size of the area when extended
5. Supplementary size in pixels;
6. Show pages preview
7. Enabling the scroll with the mouse wheel;

Figure 139. Visual settings for the application
8. Enabling the smooth scroll when navigating between objects;
9. Animate the area including active elements;
10. Animation frame rate;
11. Showing the preview of objects being inserted;
12. The transparency of the preview;
13. Ruler units (pixels, centimeters, millimeters, inches);
14. The spacing between minor ticks
15. The spacing between major ticks.

Search settings

In this window the following settings can be configured:

1. Time to start the research (in milliseconds or after pressing the Tab button
2. Show the previous research request;
3. Repeat previous search when opening the window
4. Jump to event/action object;
5. Open event/action edit dialog;
6. Sorting search results;
7. Sort order (ascending, descending, do not sort);
8. Sort type (by layer, by name, by text, by object type);
9. Group objects by pages
10. Default search properties for objects
In this window the following settings can be configured:

**Settings for the dynamic preview:**

1. Automatic closing of previously previewed objects
2. Displaying the previewed objects above all windows
3. Launching the screenshot making tool when launching the preview
Settings for image preview

1. Selecting images for preview (Each unlinked object, Divide by guidelines, All together, Without selection)
2. Setting gaps for the selection in pixels

Settings for components

Click on the icon above to configure these settings.

In the window shown on the figure below you can configure the properties for all components inserted into the prototype:
Figure 142. Settings for components
6. Actions

*Actions* are a key feature that provides the prototypes created in *GUI Machine* with interactivity. An action consists of two elements – the event being the action trigger and the action itself.

*Actions* can be triggered by the following events: mouse manipulations, pressing keyboard combinations, the changing of the focus.

Actions may have such *results* as changing objects properties, opening/closing windows, establishing connections between objects.

6.1. Adding actions

In *GUI Machine* there are several ways:

➢ With the help of the *context menu*:

➔ select the object of an action
➔ press the right mouse button and open the context menu;
➔ select the item *Add action*;
➔ click on the object of the action.

If the object of the action has not been added on the edit area, you can edit by clicking on the *Components* panel.

You can create several actions for one object. Select the item *Add action* in the context menu as many times as it is necessary to create the actions. After adding the first action the interface of creating the second one will open.

➢ By pressing the button on the *Layers* panel:
➔ select the object of the event;
➔ press the button on the *Layers* panel.

Not all objects can become action targets or action triggers.
The following objects cannot perform the function of action triggers (event objects):

- All shapes:
  - Oval;
  - Rectangle;
  - Rhombus;
  - Polygon;
- Placeholder.

The following objects cannot become action targets:

- All shapes:
  - Oval;
  - Rectangle;
  - Rhombus;
  - Polygon;
- Placeholder.

💡 One and the same object can be the action target and the action trigger at the same time.

The interface for adding actions is shown on the figure below:

![Figure 143. Adding a new action](image-url)
By default or actions are named as **New Action (....)**. The number of the action is indicated in brackets.

It is recommended to name the actions in accordance with their function. It can make the orientation in projects containing multiple actions much easier.

In the **Event settings** field the event object is displayed. You can change the event object by pressing the button 🔄. The type of the event can be selected in the dropdown menu.

![Choose object dialog box](image)

**Figure 144. Selecting an action/event object**

Objects that cannot be used as action triggers are blocked.

In the **Action settings** field the action object is displayed. You can change the object by pressing the button 🔄. The type of the action can also be selected in the dropdown menu.

- The event object and the action object can be located on different pages. Such actions are called multipage actions.
Configure the action and press the button **Add action**.

Events and actions related to objects are marked by 🕰️ and 🕳️ signs in the tree-like structure on **Layers** panel.

![Figure 145. Events and actions in the tree of objects](image)

If you double-click on the signs, the interface for editing actions will open.

On the edit area each action is marked by an arrow directed from the action trigger (event object) towards the action target. The type of the event and that of the image are denoted by icons.

![Figure 146. Icons denoting actions on the edit area](image)
If the event object or the action object is removed, the action is also removed.

One and the same object can be a part of multiple actions.

In chapters 6.3. Event types и 6.4. Types of actions the types of events and actions are described in details.

### 6.2. Editing and removing actions

There are two ways of **editing** actions:

- By a double-click on an action or on an event in the *Layers* tree.
- By pressing the button 🕒 on the *Layers* panel. This button works only when an action or an event is selected.

The interface of editing actions is similar to that of adding actions:

![Edit action interface](image)

**Figure 147. Editing actions**
The two interfaces differ only in headers and control buttons. Edit the actions and press the button **Save changes**. To undo the changes press **Cancel**.

There are several ways for removing actions:

- By pressing **Delete action** on the action editing panel.
- By selecting the object to be removed in the tree of objects and pressing the button ✗ on the **Layers** panel.
- By removing either the object of the event or the object of the action.
### 6.3. Event types

A set of events for a concrete objects depends upon its type. There are unique (related to only one type of objects) and repeatable (related to several types of objects) events.

All event types are described in the table below

*Table 33. Types of events*

<table>
<thead>
<tr>
<th>Icon</th>
<th>Event</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="button_icon.png" alt="Button click icon" /></td>
<td>Button click</td>
<td>The action is performed when one of mouse buttons is clicked. It can also be performed on pressing <em>Space</em> and <em>Enter</em> keys.</td>
</tr>
</tbody>
</table>
| ![Focus gain/loss icon](focus_icon.png) | Focus gain/focus loss | The action will be performed on gaining/losing the focus by the selected object.  
Settings:  
➢ Focus gain;  
➢ Focus loss;  
➢ Changing focus state |
| ![Check state change icon](state_icon.png) | Check state change | The action will be performed on changing the state of the object:  
Settings:  
➢ Selected;  
➢ Unselected;  
➢ Opposite to the current |
| ![Item selection icon](item_icon.png) | Item selection | The action will be performed on selecting an item in the list. To indicate the item enter its number. The numeration of items begins with 0.  
Settings:  
➢ -1 — any item;  
➢ 0 — the first item  
➢ 1 — the second item; |
| Mouse event | The action will be performed after the selected mouse event:  
|            | ➢ Mouse button click:  
|            |   ✓ Left button  
|            |   ✓ Mouse wheel;  
|            |   ✓ Right button;  
|            |   ✓ Any button;  
|            | ➢ Pressing mouse button:  
|            |   ✓ Left button;  
|            |   ✓ Mouse wheel;  
|            |   ✓ Right button;  
|            |   ✓ Any button;  
|            | ➢ Releasing mouse button:  
|            |   ✓ Left button;  
|            |   ✓ Mouse wheel;  
|            |   ✓ Right button;  
|            |   ✓ Any button;  
|            | ➢ Mouse enter into the area of the selected object;  
|            | ➢ Mouse exit from the area of the selected object;  
|            | ➢ Scrolling the mouse wheel:  
|            |   ◀ Up;  
|            |   ◀ Down;  
|            |   ◀ In any direction.  
<p>|            | You can specify the area for this type of events.  |
| Key event | The action is performed by pressing the key combination specified by the user. |</p>
<table>
<thead>
<tr>
<th>Event Type</th>
<th>Description</th>
<th>Details</th>
</tr>
</thead>
</table>
| Dropdown list item selection | The action will be performed if one of the elements of the dropdown list is selected. | Settings:  
➢ selection of any element;  
➢ selection of the empty element;  
➢ selection of the definite element. |
| Table cell selection | The action will be performed if one of the table cells is selected. You can select a cell in the table preview. | |
| Pop-up menu item selection | The action will be performed if an item in the popup menu is selected. For the items Radiobutton and Checkbox the additional settings are available: |  
➢ Item selected  
➢ Item deselected;  
➢ Any other changing of the state. |
| Collapsible pane expanded | The action will be performed if the collapsible pane is collapsed/expanded | Settings:  
➢ Expanded;  
➢ Collapsed;  
➢ Any state change. |
<table>
<thead>
<tr>
<th>Action</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Timer countdown completion</td>
<td>The action is performed when the countdown of the timer is completed.</td>
</tr>
<tr>
<td>Timer event</td>
<td>The action will be performed when the new cycle of the timer begins.</td>
</tr>
<tr>
<td>Settings</td>
<td></td>
</tr>
<tr>
<td>-1</td>
<td>each cycle;</td>
</tr>
<tr>
<td>0</td>
<td>the first cycle;</td>
</tr>
<tr>
<td>1</td>
<td>the second cycle;</td>
</tr>
<tr>
<td>etc.</td>
<td></td>
</tr>
<tr>
<td>Closing window</td>
<td>The action will be performed if the window is closed in any of the following ways:</td>
</tr>
<tr>
<td>Settings</td>
<td></td>
</tr>
<tr>
<td>before closing window</td>
<td>the action will be performed before closing the window;</td>
</tr>
<tr>
<td>after closing window</td>
<td>the action will be performed after closing the window</td>
</tr>
<tr>
<td>Tab selection</td>
<td>The action will be performed if one of the tabs of a tab-panel is selected.</td>
</tr>
<tr>
<td>Exact tab selection</td>
<td>Select the checkbox Exact tab selection if you would like to select the concrete tab as the action trigger.</td>
</tr>
<tr>
<td>Icon</td>
<td>Feature</td>
</tr>
<tr>
<td>------</td>
<td>---------</td>
</tr>
</tbody>
</table>
| 🎨 | Tree item selection | The action is performed when an item in the tree is selected. Select one of the following options (**Exact selecting elements**):
  - **On any marked object selection** — the action will be performed if any of the tree items is selected;
  - **On all marked object selection** — the action will be performed when all elements of the tree are selected.

If the checkbox is deselected, the action will be performed is anyone of the tree elements is selected. |
| 📩 | Receiving a message | Receiving a message on the port specified by the user |
6.4. Types of actions

The set of actions that can be added to an object depends upon its type. All actions can be divided into the unique (related to only one type of objects) and repeated (related to several types of objects).

All types of actions are described in the figure below.

Table 34. Types of actions

<table>
<thead>
<tr>
<th>Icon</th>
<th>Action</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>📜</td>
<td>Text change</td>
<td>Changing of formatting the text of the object. The text can be edited in the Text and HTML-editor.</td>
</tr>
<tr>
<td>💡</td>
<td>Enable/Disable</td>
<td>Allows to enable/disable the activity of the selected object. The following options are available:</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Enable</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Disable</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Change state to opposite.</td>
</tr>
<tr>
<td>👀</td>
<td>Visibility</td>
<td>Allows to configure the visibility of objects. The following options are available:</td>
</tr>
<tr>
<td></td>
<td></td>
<td>➢ Show;</td>
</tr>
<tr>
<td></td>
<td></td>
<td>➢ Hid;</td>
</tr>
<tr>
<td></td>
<td></td>
<td>➢ Change state to opposite.</td>
</tr>
<tr>
<td>📁</td>
<td>Inserting an objects of clearing the cells</td>
<td>This action is described in details in 6.4.1. Inserting an object or clearing layout cells.</td>
</tr>
<tr>
<td></td>
<td>of a dynamic layout</td>
<td></td>
</tr>
<tr>
<td>Action</td>
<td>Description</td>
<td></td>
</tr>
<tr>
<td>--------------------------------------------</td>
<td>-----------------------------------------------------------------------------</td>
<td></td>
</tr>
<tr>
<td>Progress state change</td>
<td>The checkbox <strong>Indeterminate progress bar</strong> allows to change the state of the bar to the indeterminate. To specify the value of the progress bar enter it in the <strong>Progress</strong> field. If the checkbox <strong>Indeterminate progress bar</strong> is selected, the Progress field is blocked.</td>
<td></td>
</tr>
<tr>
<td>Closing/Opening the window</td>
<td>The action is described in details 6.4.2. Opening/closing windows.</td>
<td></td>
</tr>
<tr>
<td>Window pack</td>
<td>Allows to optimize the size of the window so that it be enough for containing the objects inserted into it. If a dynamic layout is inserted into the window, the zones whose size is indicated in percentage of the free space, will act as zones whose size as indicated as preferred.</td>
<td></td>
</tr>
<tr>
<td>Moving/resizing window</td>
<td>The action is described in details in 6.4.3. Moving / resizing window.</td>
<td></td>
</tr>
<tr>
<td>Show pop up menu</td>
<td>Allows to display the pop up menu over the object of the action</td>
<td></td>
</tr>
<tr>
<td>Icon</td>
<td>Action</td>
<td>Description</td>
</tr>
<tr>
<td>------</td>
<td>--------</td>
<td>-------------</td>
</tr>
<tr>
<td>➡️</td>
<td>Perform click</td>
<td>After the event specified by the user the object of the action will be clicked upon as if by the mouse. Settings ➢ Click delay Allows to enter the time (in milliseconds) after which the object will be clicked upon. 1000 milliseconds = 1 second</td>
</tr>
<tr>
<td>🅰️</td>
<td>Focus transfer</td>
<td>Allows to transfer the focus to the selected object</td>
</tr>
<tr>
<td>🔈</td>
<td>Play</td>
<td>Allows to start playing a sound file</td>
</tr>
<tr>
<td>🔗</td>
<td>Stop</td>
<td>Allows to stop playing a sound file</td>
</tr>
<tr>
<td>🟡</td>
<td>Add icon to tray</td>
<td>Allows to add an icon to the tray</td>
</tr>
<tr>
<td>🟢</td>
<td>Remove icon from tray</td>
<td>Allows to remove the icon from the tray</td>
</tr>
<tr>
<td>🟥</td>
<td>Show tray message</td>
<td>The detailed description of this actions is given in 6.4.4 Actions for displaying the message in the tray icon</td>
</tr>
<tr>
<td>📈</td>
<td>Change icon</td>
<td>The detailed description of this actions is given in 6.4.5. Changing the appearance of the tray icon</td>
</tr>
<tr>
<td>🕒</td>
<td>Count action (for clocks)</td>
<td>This action is designed for timers. Settings: 1. Start count (launches the timer) 2. Pause count 3. Stop count</td>
</tr>
<tr>
<td>📚</td>
<td>Tab selection</td>
<td>Allows to select a tab on the tabbed panel.</td>
</tr>
<tr>
<td>Icon</td>
<td>Description</td>
<td>Details</td>
</tr>
<tr>
<td>------</td>
<td>---------------------------</td>
<td>-------------------------------------------------------------------------</td>
</tr>
<tr>
<td>📡</td>
<td>Collapsing the panel</td>
<td>Allows to collapse/expand or change the state of a tabbed panel. Settings:</td>
</tr>
<tr>
<td></td>
<td></td>
<td>➢ Collapse;</td>
</tr>
<tr>
<td></td>
<td></td>
<td>➢ Expand;</td>
</tr>
<tr>
<td></td>
<td></td>
<td>➢ Change the state to opposite</td>
</tr>
<tr>
<td>💌</td>
<td>Sending a message</td>
<td>Allows to send a message to the port specified by the user.</td>
</tr>
</tbody>
</table>
6.4.1. Inserting an object or clearing layout cells

This action is very useful for creating

This action can work in three ways:

➢ inserting an object into layout cells;
➢ clearing the cells of the layout;
➢ inserting an object into the cells without clearing them

6.4.1.1. Inserting an object into layout cells

For inserting objects into cells the **Object** checkbox should be selected:

![Image of GUI Machine interface](image.png)

Figure 148. Settings for inserting action
Select the object to be inserted from the tree by pressing the button \( \text{Add} \).
In the field located on the left of the button the name of the object being inserted will be displayed.

Select the item to insert the object in the sketch of the layout in the lower part of the window. Then press the \textit{Save} button.

\textit{Example.}
The task is to insert a calendar into the cells marked with red after pressing the appropriate button (figure 149):

![Figure 149. Inserting a calendar into layout cells](image)

Add the action \textbf{Object insert or cells clear} and configure its settings as follows(fig. 150):

- the event object: VaadinButton5 (Calendar);
- the object of the action: dynamic layout

Select the Object checkbox and add VaadinCalendar2 from the tree-like structure. Press the button \textit{Add action}.
The work of the action is shown on the figure below:
6.4.1.2. Clearing layout cells

To clear the cells deselect the checkbox **Object**. The text of this checkbox will be changed into **Clear cells** and the object selection field will be blocked (figure 152).

In the sketch of the layout select the cells to be cleared. This action is configured similarly to the action of inserting objects into the layout described above.

6.4.1.3 Inserting an object without clearing cells

The default settings for the action of inserting suppose that the cells the inserting of a new object the cells are cleared. If you do not want to clear the cells, deselect the checkbox **Clear cells before insert**. New objects will be inserted without deleting the existing content.
6.4.2. Opening/closing windows

Almost all interfaces include windows. It is impossible to create a realistic prototypes without actions related to windows.

The objects of the action:

➢ Window;
➢ Vaadin window.

Select the necessary option:

➢ Open;
➢ Close;
➢ Change state to the opposite.

If you choose the option **Close** all other fields will be blocked:

There is no need to configure any additional settings. Save the action and check it for correctness.
If you select the options **Open** or **Change state to opposite**, the additional settings are available.

The checkbox **Do not move outside screen bounds** allows/prohibits to locate the window beyond the borders of the screen.

There are four options for locating the opening window on the screen:

- **Under event object** (the window opens right under the object of the event. The fields for setting coordinates are blocked).
- **Middle of the screen** (the window opens in the center of the screen. The fields for setting coordinates are blocked);
- **Relative to object** (the shifting of the object relative to the upper left point of the object of the action is entered in coordinates \( x,y \))
- **Exact \( x,y \) coordinates** (the shifting of the object relative to the upper left corner of the screen is entered in coordinates \( x, y \)).

## Settings for the coordinates of object shifting

Coordinates \( X, Y \) can be specified by two ways:

- in exact number of pixels;
- in special parameters

Th coordinates in **exact number of pixels** can be set us:

- \( 0,0 \) for locating the upper left point of the window exactly in the left upper point of the event object (over the object) or in the left upper point of the screen;
- \( -1,-1 \), in this case:
  - if you select the option **Relative to object** the window will be located over the object;
  - if you select the option **Exact \( x,y \) coordinates** the coordinates of the object will remain the same to those of the last opening (if the window is opened for the first time, it will be located in the center of the screen);
- any integral number (including minus ones) for upward and leftward shifting

When setting the coordinates with **special parameters** you can use the following values:

- \( \{x\} \) и \( \{y\} \) — coordinates of the event object relative to the upper left point of the screen;
- \( \{\text{width}\} \) и \( \{\text{height}\} \) — the width and the height of the event object;
- \( \{\text{window.width}\} \) и \( \{\text{window.height}\} \) — the width and the height of the window being opened;
- \( \{\text{screen.width}\} \) и \( \{\text{screen.height}\} \) — the width and the height of the screen.

It is also possible to use the following **mathematical operations**:  

- + addition;
- - subtraction;
➢ * multiplication;
➢ / division.

When you right-click on the window the context menu with all possible settings will appear.

Example:

➢ If the option **Relative to object** is selected:

   ➔ \( X=0, \ Y=(\text{height}) \) — locating the window under the object:

   ![Figure 155. A window under the object](image)

   ➔ \( X=(\text{width}), \ Y=-(\text{window.height}) \) — locating the window over the upper right corner of the object:

   ![Figure 156. A window over the right upper corner](image)

➢ If the option **Exact x,y coordinates** is selected:

   ➔ \( X=(\text{screen.width})-(\text{window.width}), \ Y=(\text{screen.height})-(\text{window.height}) \) — locating the window in the lower right corner of the screen;

   ➔ \( X=(\text{screen.width})/2-(\text{window.width})/2, \ Y=(\text{screen.height})/2-(\text{window.height})/2 \) — locating the window in the center of the screen;

   ➔ \( X=0, \ Y=0 \) — locating the window in the left upper corner of the screen.
6.4.3. Moving / resizing window

This action allows to resize windows and change their position.

The object of the action:

➢ Window;
➢ Vaadin Window.

![Image of GUI Machine User's Manual](image)

Figure 157. Settings for moving/resizing windows

The checkbox **Do not move outside screen bounds** allows/prohibits to locate the window beyond the borders of the screen.

For **moving** the window enter the coordinates $X,Y$. Thus the shifting of the window being opened relativ to the upper left corner is configured.

To **resize the window** enter the **width** and the **height**.

### Configuring settings for moving/resizing windows

Coordinates $X,Y$ as well as the **width** and the **height** can be configured in two ways:

➢ in exact number of pixels;
➢ with special parameters.

The coordinates in **exact number of pixels** can be entered as follows:

➢ **0,0:**
  ○ $X,Y$ for moving the window to the left-upper corner of the screen;
  ○ **width, height** for reducing the size of the window to smallest possible one.
-1,-1, in this case the action will not be moved or resized;
- any integer number for the indication of the position or the size of the window.

When configuring the coordinates with special parameters you can use the following values:

- \( \{x\} \) и \( \{y\} \) — a coordinates of the position of the window relative to the upper left point of the screen;
- \( \{\text{width}\} \) и \( \{\text{height}\} \) — the width and the height of the window;
- \( \{\text{screen.width}\} \) и \( \{\text{screen.height}\} \) — he width and the height of the screen.

It is also possible to use the following mathematical operations:

- + addition;
- - substraction;
- * multiplication;
- / division.

When you right-click on the field, the context menu with all settings will appear. Click on the necessary item to insert it in the field being edited.

Examples:

- \( X=\{x\}+\{\text{width}\} \), \( Y=\{y\}+\{\text{height}\} \) — moving window rightwards and downwards from the current position:

  ![Figure 158. Moving the window rightwards and downwards](image)

- \( \text{Width}=\{\text{Width}\} \), \( \text{Height}=\{\text{Width}\} \) — makes the width equal to the height;
- \( \text{Width}=\{\text{Width}\}*2 \), \( \text{Height}=\{\text{Width}\}*2 \) — doubles the size of the window;
➢ X=0, Y=0, Width={screen.width}, Height={screen.height} — the window will be expanded to the size of the screen;

➢ X={x}-100, Y={y}-200 — the window will be moved 100 pixel leftward na 200 pixels upward from the current position.

6.4.4 Actions for displaying the message in the tray icon

The object of the action: tray icon

You can select one of the following types of the message displayed:

➢ error;
➢ warning;
➢ information;
➢ message

![Action settings](image)

Figure 159. Selecting the type of the message to be displayed in the tray.

The text entered in the **Caption** field is displayed in bold type as the name of the message appearing in the tray.

The text of the message itself is entered in the **Message** field.

If you select **Error** as the type of the message and configure the settings as it is shown on the figure below:
the following message in the tray should appear after configuring this settings:

![Message in the tray](image)

**Figure 161. A message in the tray**

**NB:** The actions for the tray icon will be performed only if the icon has been added to the tray by another action.

### 6.4.5. Changing the appearance of the tray icon

This action allows to change the image used as the icon in the tray.

Object of the action: tray icon
6.4.6. Connecting the prototype with other prototypes and applications

GUI Machine allows to connect the prototype with other prototypes and applications. Select the component Connector object from the Extended set. The connector object can become the target of actions of different types (pressing a button, selecting a checkbox, etc.)

Example

The action of sending a message by pressing a button is configured in the following way:

1. Add a button and a connector object on the edit area. Select the connector object as the target object of the action.
2. In action settings indicate the number of the port and enter the text of the message to be sent:
If you want to trigger an action by receiving a message on the specified port do the following:

1. In the event settings for the connector object specify the event *Receiving a message* and enter the text.
2. In action settings specify the action to be performed after receiving the message. If you want the action to be performed after the concrete message is received, select the checkbox *Certain message* (figure 164):

![Figure 164. Settings for receiving a message](image)

© 2007-2011 ALEE Software

GUI Machine 1.5.8
7. Real-time preview of prototypes

7.1 Previewing objects

7.1.1 Previewing objects in GUI Machine

This tool allows to preview prototypes, their elements and single objects in real-time mode. It also allows to control the work of objects and make screenshots of the interfaces. During the preview prototypes look like real working programs.

The look of the prototype being previewed differs from that on the edit area. It is recommended to preview prototypes when working upon them.

Not all objects can be previewed. The following objects cannot be previewed:

- Pop-up menus;
- Timer;
- Tray icon;
- Connector object;
- Audio player.

There are several ways to preview the selected object:

- by opening the context menu of the object and selecting the Preview item:

![Figure 165. Launching preview in the context menu](image)

- By pressing the button in the upper toolbar:
By pressing **F5**

If there are several objects on the edit area, it is impossible to preview them all at the same time. However, the objects can be previewed separately.

![Figure 166. The button for launching preview in the upper toolbar](image)

You can create the bookmark of the object for the quick launch. Select the object and press the button ![Selected](image) in the upper toolbar.

![Figure 167. Preview of an object with different properties](image)

The bookmark will be added to the list. To launch the preview select the necessary object from the dropdown list and press the button ![Selected](image).

To remove the bookmark select the object and press the button ![Selected](image).

To return to the default preview mode choose the item **Selected** in the dropdown list.

You can preview either interface or its separate parts:
To stop the preview it is sufficient to close the window of the prototype. If the window cannot be closed in the standard fashion, press **Alt+F4**.

It usually takes a long time to launch the preview of objects containing numerous objects and actions.
7.1.2 Previewing objects in GUI Machine Viewer

GUI Machine Viewer allows to preview prototypes saved in *.gdv format without launching GUI Machine. It is installed automatically when installing the program. It is sufficient to double-click on a *.gdv file to launch its preview.

GUI Machine Viewer can also be launched from the Start menu (Start→Programs→GUI Machine→GUI Machine Viewer). Select an object for preview in the window that should open:

![GUI Machine Viewer](image)

Figure 170. Selecting an object for preview

Select the object and press the **Open project button**.
Depending on project setting either the object marked as the main will be launched or the window for selecting the object for the preview will be opened:
Selecting the radiobutton **Preview other object** you can preview any other object of the project:
7.2 Export tools

7.2.1 Exporting prototypes

Prototypes can be exported and launched as fully-functional applications. Select **File → Export prototype** in the main menu. The following window should open:

![Settings for exporting prototypes](image)

Specify the folder in which you would like to save the prototype in the field **Save directory**. Configure the settings for the preview of the prototype. You can select any of the objects included in the prototype as the main launchable object.

Select the operating system under which the prototype will be launched in **Export settings**. You can select several operating systems at once. Press the **Export now** button. The following window should appear:

![The progress of the export of the prototype](image)

After exporting the prototype is saved in the directory named after the operating system. If you select several folders will be created.

The exported prototype can be previewed on any other computer. It is not necessary to install GUI Machine or GUI Machine Viewer: just open the folder and launch the file **designreviewer.exe** or **designreviewer.sh**.
7.2.2. Exporting images
The image export tool allows to make configurable screenshots of the edit area.

The tool is launched:

➢ by selecting **File → Save images** in the main menu ;
➢ by pressing **Ctrl+Q**.

The following window will open:

![Image Export Tool](image.png)

**Figure 175. The preview of the edit area**

The main window of the tool can be divided into three parts:

➢ the **Images** panel ;
➢ the **Settings** panel;
➢ the workspace.
The workspace

The workspace is a snapshot of the part of the edit area occupied by objects. The part not containing objects is not displayed.
You can navigate the snapshot in one of the following ways:

- by pressing the middle mouse button;
- by holding pressing the left mouse button and holding the Space key;
- by pressing the arrow keys and Ctrl+Home, Ctrl+End.

The blue box on the workspace displays the borders of the snapshot. It is possible to move the box by pressing the left mouse button and to resize it. The area outside the box is covered by the semitransparent layer. The degree of opacity of this level can be configured.

If there are several snapshots on the workspace, each of them is displayed in a box. The box of every snapshot can be modified.

The first snapshot is made automatically at the launch of the tool. Its box outlines the region occupied by all objects.

The image panel

The tools of the panel are described in the table below.

Table 35. The tools of the Image panel

<table>
<thead>
<tr>
<th>Button</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Add image" /></td>
<td>Add image</td>
</tr>
<tr>
<td><img src="image" alt="Add smart image" /></td>
<td>Add smart image</td>
</tr>
<tr>
<td><img src="image" alt="Delete selected image" /></td>
<td>Delete selected image</td>
</tr>
<tr>
<td><img src="image" alt="Delete all images" /></td>
<td>Delete all images</td>
</tr>
</tbody>
</table>

The list of snapshots is displayed under the toolbar. To rename a snapshot double-click on it and enter the new name in the window that will open:

![Rename window](image)

Figure 176. Renaming a snapshot
The Settings panel

**Background** - the settings for the background.
The checkbox *Fill background* allows to enable/disable the displaying of the background. If the checkbox is deselected, the alpha-layer is displayed and the settings for the background color are blocked.

Settings for the background color:

<table>
<thead>
<tr>
<th></th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>A</td>
<td>The field for selecting the main background color</td>
</tr>
<tr>
<td>B</td>
<td>Default colors (black and white);</td>
</tr>
<tr>
<td>C</td>
<td>Switching between colors;</td>
</tr>
<tr>
<td>D</td>
<td>The field for selecting the additional background color</td>
</tr>
</tbody>
</table>

**Area shadowing** — the opacity of the shadowing layer (from 0% up to 100%, where 0% is absolutely transparent, 100% is absolutely opaque).

**Smart selection border spacing** — settings for configuring smart selection borders.
The spacing can be configured by entering the size in the appropriate fields:

- Top — the upper spacing;
- Left — the left spacing;
- Bottom — the bottom spacing;
- Right — the right spacing.

![Smart selection border spacing](image)

Figure 177. Configuring the spacing
Making a snapshot

To make a new snapshot:
➢ press the snapshot creation button or the A key;
➢ holding the left mouse button select the snapshot area on the workspace.

The new snapshot will be added to the list.

Creating smart images

With smart snapshots you need not select the area manually, for it is selected automatically when clicking on the object. The area is set above the object that has been clicked. The spacing settings are taken into consideration.

To make a smart snapshot:
➢ press the button for creating smart snapshots or the S key;
➢ on the workspace click on the object the snapshot of which you would like to add.

An example of creating a smart snapshot is given on the figure below. The following objects have been left-clicked upon successively:
➔ the Align left button;
➔ the Large icon-text gap button;
➔ the Text at bottom button.

Figure 178. Making a smart snapshot
As the spacing was set as (5; 5; 5; 5), these settings were taken into consideration. Three new images have been added to the list. Smart snapshots are named automatically after one of the object properties:

1. Text;
2. Text on selection;
3. Border header;
4. Tooltip text;
5. The name of the object

In the list of properties their priority is taken into consideration. If all properties are configured, the snapshot is name after the text of the object. If the value of the Text property is empty, the object is named after the Text on selection, and so on.

### Saving images

After creating the snapshot press the Save button in the lower right corner. Select the location for saving the snapshots in the window that will open and press the Save button. If the names of the files in the selected directory coincide with those of the created screenshots, the following window will open:

![File conflict window](image.png)

**Figure 179. File conflict**

You can do the following:

- **Replace the existing file** — the existing file will be replaced by the new one;
- **Save both files** — the both files will be saved. The new snapshot will be saved with the new name.
- **Skip this file** — the old file will remain unchanged and the new one will not be saved.

Select the checkbox **Do same action for all conflicts** in order to repeat the selected operations in case of future conflicts.
7.2.3 Exporting screenshots

The screenshot making tool allows to create and export the screenshots of the prototype automatically. Select the item **Export screenshots** in the **File** menu.

The window containing the previews of all objects saved for quick preview launch will open:

![The main window of the screenshot export tool](image)

Drag the objects whose screenshots you would like to make to the central part of the window. Delete the objects whose screenshots you do not need by clicking on the button ✗ or pressing the Delete key. The objects can be added/removed by double-clicking on their icons in the tree. The button ✖️ allows to add all the objects saved for quick launch by a single click. The button ✗️ allows to add all the windows of the project by a single click.
The button allows to add all the unlinked object of the project by a single click. If you need to get screenshots without window headers and borders, select the checkbox **Save content only.**

Select the color for the background of the windows being shot in the dropdown menu **Background color.** Enter the time interval between the object launch and making its screenshot in the field **Screenshot delay.**

If you need to use the actions in the launched objects, deselect the checkbox **Do not load actions.**

All screenshots are combined into sets and saved together with the project. The saved sets can be opened even on other computers. You can select the sets of screenshots in the dropdown menu. Press the button to rename the set of screenshots. You can add a new set of screenshots by pressing the button. To delete a set of screenshot select it and press the button.

Select a folder to save the screenshots at the bottom of the window.

Click on the **Export** button. The screen will be painted with the background color you selected and the windows will be opened, shot and closed automatically. When the work is finished the folder in which the screenshots are saved will be opened.
8. Context menu

The context menu allows to access to the most frequently used tools quickly and to perform some operations with objects.

To open the context menu for an object (or for a group of objects) select them and press the right mouse button. If you do not want the context menu to be related to any particular object, do not select any object on the edit area and press the right button.

The context menu is displayed for the object being selected at the given moment. If you approach the cursor to an object which is not selected it is highlighted. When you press the right mouse button, it will be selected and its context menu will be displayed.

Figure 181. The context menu

💡 For some objects certain items of the context menu can be blocked.

The detailed information about the items of the context menu is given in the table below.
Table 36. The items of the context menu

<table>
<thead>
<tr>
<th>Icon</th>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>![ ]</td>
<td>Preview</td>
<td>Launches the preview of the selected object</td>
</tr>
<tr>
<td>![ ]</td>
<td>Add actions</td>
<td>Allows to specify the selected object as the trigger of an action. After selecting this item the target object is selected.</td>
</tr>
<tr>
<td>![ ]</td>
<td>Object events</td>
<td>Displays the events related to the object</td>
</tr>
<tr>
<td>![ ]</td>
<td>Object actions</td>
<td>Displays the actions related to the object</td>
</tr>
<tr>
<td>![ ]</td>
<td>Edit</td>
<td></td>
</tr>
<tr>
<td>![ ]</td>
<td>Edit → Undo</td>
<td>Allows to cancel the last of the previously performed operations.</td>
</tr>
<tr>
<td>![ ]</td>
<td>Edit → Repeat</td>
<td>Brings the last canceled operation back.</td>
</tr>
<tr>
<td>![ ]</td>
<td>Edit → Cut (x)</td>
<td>Allows to cut the selected objects; x stands for the number of objects</td>
</tr>
<tr>
<td>![ ]</td>
<td>Edit → Copy (x)</td>
<td>Allows to copy the selected objects; x stands for the number of objects</td>
</tr>
<tr>
<td>![ ]</td>
<td>Edit → Paste</td>
<td>Allows to paste objects from the clipboard</td>
</tr>
<tr>
<td>![ ]</td>
<td>Edit → Clone selected objects</td>
<td>Clones the selected object</td>
</tr>
<tr>
<td>![ ]</td>
<td>Edit → Remove selected objects(x)</td>
<td>Allows to remove the selected objects; x stands for the number of objects</td>
</tr>
<tr>
<td>![ ]</td>
<td>Hide selected objects (x)</td>
<td>Allows to hide the selected objects; x stands for the number of objects</td>
</tr>
</tbody>
</table>
Show all hidden objects (Total hidden: \( x \))

- Allows to show all hidden objects on the edit area; \( x \) stands for the number of hidden objects.

Move object to top layer

- Allows to bring the selected object on the top layer.

Move one layer up

- Allows to raise the selected object on one layer.

Move one layer down (Bring the object)

- Brings the selected object one layer down.

Move object to bottom layer

- Brings the selected object to the bottom layer.

Aligning

- Allows to align object and configure the settings for the alignment. This item is equal to the appropriate items in **Tools and Frames** menu.

In the **Objects under cursor** section of the context menu the objects located beyond the mouse cursor are numbered. The objects are arranged by layers (from the bottom layer to the lower one).

The maximal number of objects displayed in the context menu is 10. If there are more than 10 objects under cursor, the context menu looks as it is shown on the figure below:

![Objects under cursor](image)

**Figure 182. The lower section of the context menu**

To display other objects click on ... (dots).
The following window will open:

![Object selection window](image)

Figure 183. Objects under mouse cursor

If the objects are linked to each other and form a tree, they are displayed as tree-like structure:

![Object hierarchy](image)

Figure 184. The tree of objects under the mouse cursor
For some types of objects the additional items are added to the context menu.

### Additional items for menus

![Delete menu "File"
Add menu before "File"
Add menu after "File"
Choose popup for menu "File"](image)

Figure 185. Additional item for menus

The detailed description of the additional items is given in the table below.

**Table 37. Additional items of the context menu for menus**

<table>
<thead>
<tr>
<th>Icon</th>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt=" " /></td>
<td>Delete menu <code>&lt;name&gt;</code></td>
<td>Allows to remove the selected menu item</td>
</tr>
<tr>
<td><img src="image" alt=" " /></td>
<td>Add menu before <code>&lt;name&gt;</code> »</td>
<td>Allows to add a new item preceding the selected item. Double-click on the item to rename it.</td>
</tr>
<tr>
<td><img src="image" alt=" " /></td>
<td>Add menu after <code>&lt;name&gt;</code></td>
<td>Allows to add a new item following the selected item. Double-click on the item to rename it.</td>
</tr>
<tr>
<td><img src="image" alt=" " /></td>
<td>Select popup menu for the item <code>&lt;name&gt;</code></td>
<td>Allows to choose the pop up menu for the selected item. Select this item and click on the pop up menu on the edit area.</td>
</tr>
</tbody>
</table>

### Additional item for placeholders

![Select an object to be replaced](image)

Figure 186. The additional item in the context menu for placeholders
This item allows to select an object to be replaced by the placeholder. After selected this item click on the object on the edit area.
If an object is being replaced by the placeholder, two more items are added:

![Unlink the replaced object](image)
![Show the replaced object](image)

Figure 187. Additional items for the placeholder replacing an object

If you select the item Unlink the replaced object the link between the placeholder and the object it replaces will be canceled.

### Additional context menu items for windows

For windows with no menus linked two more items are added to the context menu:

- Choose window menu bar
- Choose default focus component

Figure 188. The additional context menu items for windows without menus

The item **Choose window menu bar** allows to select a menu for the window. Click on the menu on the edit area after selecting this item.

The item **Choose default focus component** allows to select the element of the window to which the focus will be transferred on opening.

If a menu is linked to the window, two more items are added:

- Change window menu bar
- Unlink window menu bar

Figure 189. Additional items for windows containing menus

The item **Change window menu bar** allows to replace the existing menu by a new one. Click on a new menu on the edit area after selecting this item.

The item **Unlink menu bar** allows to cancel the link between the window and its menu bar.
**Additional context menu items for images**

![Edit image](image.png) ![Copy image path to clipboard](clipboard.png)

Figure 190. Additional context menu items for images

Select the item **Edit image** to launch the image editor. If you want to copy the path to the image, select the appropriate item.

**Additional context menu items for dynamic layouts**

![Add object by cells](add.png) ![Change selected cell background](change.png) ![Change cells background](change.png) ![Clear cells background](clear.png) ![Set all px columns width](set.png) ![Set all px rows height](set.png)

Figure 191. Additional context menu items for dynamic layouts

The functions of all items are described in the table below.

*Table 38. Additional context menu items for dynamic layouts.*

<table>
<thead>
<tr>
<th>Icon</th>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="add.png" alt="Add object by cells" /></td>
<td>Add object by cells</td>
<td>Allows to insert an object into several layout cells. After selecting this item choose the cells for the object being inserted, and the select the object itself on the edit area.</td>
</tr>
<tr>
<td><img src="change.png" alt="Change selected cell backgrounds" /></td>
<td>Change selected cell backgrounds (Change background for the selected cell)</td>
<td>Allows to change the background for the cells specified by the user.</td>
</tr>
<tr>
<td>Icon</td>
<td>Function Description</td>
<td></td>
</tr>
<tr>
<td>------</td>
<td>----------------------</td>
<td></td>
</tr>
<tr>
<td><img src="image" alt="Icon" /></td>
<td><strong>Change cells background</strong>&lt;br&gt;Allows to change the background for all layout cells.</td>
<td></td>
</tr>
<tr>
<td><img src="image" alt="Icon" /></td>
<td><strong>Clear cells background</strong>&lt;br&gt;Allows to clear the background of layout cells</td>
<td></td>
</tr>
<tr>
<td><img src="image" alt="Icon" /></td>
<td><strong>Set px columns width</strong>&lt;br&gt;Allows to set the width for all columns whose size is indicated in pixels</td>
<td></td>
</tr>
<tr>
<td><img src="image" alt="Icon" /></td>
<td><strong>Set px columns height</strong>&lt;br&gt;Allows to set the height for all columns whose size is indicated in pixels</td>
<td></td>
</tr>
</tbody>
</table>

The detailed description of all tools described above is given in 5.3. Working with dynamic layouts.

### The additional context menu items for toggle buttons, checkboxes and radiobuttons

![Image](image)

Figure 192. The specific items for toggle buttons, checkboxes and radiobuttons

When the item **Toggle check state** is chosen, the value of the *Selected* property is changed to the opposite. You can change the value of this property for several objects at once.
9. Image Editor

The Image Editor is a simple easy-to-use tool for processing images used in prototypes. It allows to process and correct images without recourse to any other special software. It allows to perform all basic operations upon images.

**Launching the image editor**

Add an image on the edit area; then perform one of the following operations:

- double-click on the object and select an image from the file system or from the previously used images;
- select the value for the Image property
- paste an image from the clipboard by the selecting the appropriate item in the context menu or by pressing Ctrl+V.

Open the context menu and select the item **Edit Image**. The image editor will be launched.

The editor can also be launched by selecting **Tools and frames → Open image editor** in the main menu (the icon .)
Figure 193. The Image editor
9.1. Tools of the Image Editor

The tools of the Image editor are described in the table below.

Table 39. Image Editor Tools

<table>
<thead>
<tr>
<th>Icon</th>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Marquee tool" /></td>
<td>Marquee tool</td>
<td>Allows to select a part of the image</td>
</tr>
<tr>
<td><img src="image" alt="Move tool" /></td>
<td>Move tool</td>
<td>Allows to change the position for the selected region</td>
</tr>
<tr>
<td><img src="image" alt="Crop tool" /></td>
<td>Crop tool</td>
<td>Allows to select an area of the image and discard everything outside this area by pressing the Enter key.</td>
</tr>
<tr>
<td><img src="image" alt="Pencil tool" /></td>
<td>Pencil tool</td>
<td>Allows to draw and to change the opacity of the marker from 0% (transparent) to 100% (totally opaque) by moving the slider.</td>
</tr>
<tr>
<td><img src="image" alt="Paint bucket tool" /></td>
<td>Paint bucket tool</td>
<td>Allows to paint the selected area with color. The Tolerance property allows to set the color tolerance (from 0 – filling the areas whose color is similar to that of the selected point up to 239 – filling the areas whose color is different from that of the selected point). The checkbox Save pixels transparency allows save the degree of the transparency of pixels after the work of this tool.</td>
</tr>
<tr>
<td><img src="image" alt="Eraser tool" /></td>
<td>Eraser tool</td>
<td>Allows to clear the area specified by the user.</td>
</tr>
<tr>
<td><img src="image" alt="Eraser fill tool" /></td>
<td>Eraser fill tool</td>
<td>Allows to paint an area with alpha-layer.</td>
</tr>
<tr>
<td>Tool</td>
<td>Description</td>
<td></td>
</tr>
<tr>
<td>------</td>
<td>-------------</td>
<td></td>
</tr>
<tr>
<td>Eyedropper tool</td>
<td>Allows to sample a color from the image in order to use this color further.</td>
<td></td>
</tr>
<tr>
<td>Zoom tool</td>
<td>Allows to zoom images in and out (from 100% to 3200%). You can zoom images by either pressing the mouse buttons (the left button for zooming in and the right button for zooming out) or by using the slider. Images can also be zoomed out by pressing the left mouse button together with the Ctrl key.</td>
<td></td>
</tr>
<tr>
<td>Draw pixels greed</td>
<td>Allows to show/hide the greed above the image.</td>
<td></td>
</tr>
<tr>
<td>Do not fill background with color</td>
<td>Allows to switch between the alpha-layer and the selected background color.</td>
<td></td>
</tr>
<tr>
<td>Painting antialias (antialiasing)</td>
<td>Allows to anti-alias the lines made by the pencil and eraser tools.</td>
<td></td>
</tr>
<tr>
<td>Change first color</td>
<td>Allows to configure the color for the background of images.</td>
<td></td>
</tr>
</tbody>
</table>
9.3. The main menu

The main menu of the image editor is shown on the figure below:

![Figure 194. The main menu of the image editor](image)

It comprises 3 items:

- File
- Edit
- Image

9.3.1. The File item

The submenu for the File item is shown on the figure below:

![Figure 195. The File menu](image)

It includes the following items:

- Insert image
- Save and exit
- Save image as...
- Exit the editor

If you select the Insert image item, the standard image selection tool will open (Cf. Figure 73. Selecting an image from the file system)
If you select **Save and exit** item, the editor will be closed but the image will be saved. It will be opened at the next launch of the editor.

If you select **Save image as ...**, the standard interface for saving files should open. Images can be saved in the following formats:

- *.jpeg;
- *.jpe;
- *.jpg;
- *.gif;
- *.png.

### 9.3.2. The **Edit** menu

The **Edit** menu is shown on the figure below:

![Edit menu](image)

**Figure 196. The Edit menu of the image editor**

It comprises the following items:

- **Undo** — cancels the last operation performed on the image;
- **Redo** — allows to repeat the last canceled operation;
- **Cut selection** — cuts the selected area and copies it to the clipboard;
- **Copy selection** — copies the selected area;
- **Paste** — pastes an image from the clipboard
9.3.3. The **Image** menu

The **Image** menu is shown on the figure below:

![Image menu](image1)

Figure 197. The Image menu

The **Image** menu contains the following items:

- Image size;
- Canvas size.

If you select the item Image size, the window for configuring the size of the image will open:

![Image size window](image2)

Figure 198. The image size

Enter the necessary size in pixels and press **Ok**.

При выборе пункта Размер области открывается окно для установки размера области и расположения изображения: If you select the Canvas size item, the window for configuring the canvas and the location of the image should open:
To change the size of canvas enter the width and the height in pixels.

To specify the position of the image use the arrows. There are 10 possible positions for an image on the area.
9.4. Saving images

After editing the image press the *Save* button. The following window will open:

![Warning dialog](image)

After pressing the *Yes* button the source image file will be modified.

If you press the *No* button, the new image file will be created. The source file will remain unchanged.
9.5 The History tool

With the help of the History tool you can return to any previous state of the image in the current working session. Each time you bring a change a new entry is added to the History. Specify the stage you would like to return to by selecting the appropriate entry.

Operations of configuring the settings of the editor are not registered in the history for they do not modify the image.

The history is cleared after closing the editor.

Each new entry is added to the end of the list.

You can navigate the history in one of the following ways:

- by selecting an entry in the history and clicking upon it;
- by selecting the items **Undo** and **Redo** in the Edit menu;
- by pressing **Ctrl+Z** and **Ctrl+Shift+Z**;
- by selecting and entry in the History and pressing the arrow keys.
10. Pixel Grabber

*Pixel Grabber* is the tool for defining the color of display dots. It can be used when working *GUI Machine* and separately.

To launch *Pixel Grabber* select **Tools and Frames → Pixel Grabber** (the icon).

To launch *Pixel Grabber* without launching *GUI Machine* press the **Start** button. Select **All programs → GUI Machine → Pixel Grabber**.

You can also go to *GUI Machine* save directory and double-click on the file *pixelgrabber.exe*.

With the help of the *Pixel Grabber* you can define the color of any display dot in the **RGB** format. *Pixel Grabber* is very simple and easy-to-use.

![Figure 202. PixelGrabber](image)
The **PixelGrabber** tool consists of the following elements:

<table>
<thead>
<tr>
<th>Icon</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Start/Pause recording</td>
<td><strong>Icon</strong> Start/Pause recording</td>
</tr>
<tr>
<td>Eyedropper tool</td>
<td>Eyedropper tool</td>
</tr>
<tr>
<td>Image selection tool</td>
<td>Image selection tool</td>
</tr>
<tr>
<td>Zooming the recorded image</td>
<td>Zooming the recorded image</td>
</tr>
<tr>
<td>Display PixelGrabber atop all windows</td>
<td>Display PixelGrabber atop all windows</td>
</tr>
<tr>
<td>Hide preview area on the image being recorded</td>
<td>Hide preview area on the image being recorded</td>
</tr>
<tr>
<td>Show/hide cursor on the image being recorded</td>
<td>Show/hide cursor on the image being recorded</td>
</tr>
<tr>
<td><img src="#1A171B" alt="Color Value" /></td>
<td>Color value</td>
</tr>
<tr>
<td><img src="Example" alt="Example" /></td>
<td>The example of color</td>
</tr>
</tbody>
</table>

To define the color of a display dot:

1. Place the cursor in the necessary area.
2. Press the **Space** button. The **Pixel Grabber** will fix the image.
3. The image can be zoomed in with the help of the zooming tool (the images can be zoomed from 1x – 100% up to 64x - 6400%).
4. Select a display dot on the fixed image.
5. The color value in **RGB** format will be displayed in the **Color** field. In the neighboring field the color value will be displayed in the hexadecimal format. The example of the color is shown in the appropriate field.
6. Press the **Space** key or the **Continue** button.
11. The screenshot making tool (Print Screen)

**Print Screen** is an easy-to-use tool for making the screenshots of prototypes created in **GUI Machine**.

To launch **Print Screen** select **Tools and Frames → Print Screen** in the main menu (the icon ![Print Screen icon](image)). The following window will open:

![Print Screen tool](image)

Figure 203. The Print Screen tool.

The tool will be launched automatically after starting the preview of any object/interface. Press the ![Select/Unselect](image) button on the toolbar to select/unselect this option.

The interface of the tool can be divided into three parts:

- the toolbar;
- the screenshot tree;
- the available frames.
➢ the available windows.

The tool bar

The functions of the toolbar buttons are described in the table below:

Table 40. The Print Screen toolbar.

<table>
<thead>
<tr>
<th>Icon</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Add a new screenshot" /></td>
<td>Add a new screenshot</td>
</tr>
<tr>
<td><img src="image" alt="Remove the selected screenshot from the tree" /></td>
<td>Remove the selected screenshot from the tree</td>
</tr>
<tr>
<td><img src="image" alt="Create a new folder in the tree" /></td>
<td>Create a new folder in the tree</td>
</tr>
<tr>
<td><img src="image" alt="Remove the selected folder from the tree" /></td>
<td>Remove the selected folder from the tree</td>
</tr>
<tr>
<td><img src="image" alt="Refresh the screenshot tree" /></td>
<td>Refresh the screenshot tree</td>
</tr>
<tr>
<td><img src="image" alt="Enable/disable launching Print Screen during the preview" /></td>
<td>Enable/disable launching Print Screen during the preview</td>
</tr>
</tbody>
</table>

The screenshot tree

It is recommended to create a tree-like structure of folders before starting to make screenshots.

Enter the name of the folder in the window shown on the figure below:

![Directory creation](image)

Figure 204. Entering the name of the folder

To rename folders/screenshots:

- select a folder/a screenshot and press F2 ;
- double-click on the folder/screenshot

The tree is duplicated in the file system (in the folder Screenshots located in the project directory). If you modified the tree in the file system, refresh it by pressing the appropriate button so that it be displayed correctly in Print Screen main window.
Available windows

In the list of available windows the following elements are displayed:
- interfaces being previewed;
- objects linked to the interfaces being previewed by means of actions.

NB:
- interfaces not being previewed are displayed as disabled;
- if you click on the interface being previewed, it will be displayed atop all windows;
- the screenshot of the interface being previewed is created when clicking upon it.

Making a screenshot

When you press the **Add screenshot** button, the main window of the instrument will be hidden and the interface being previewed will be covered by the semitransparent layer:

![Figure 205. Making a screenshot](image)

The layer specifies the region of the screen that will be shot. The layer can be moved by the corners and thus resized. If you right-click on the layer, it will cover the content of the window:

![Figure 206. A screenshot of window content](image)

Right-click on the layer to return to the previous size.
To make the screenshot the window covered by the layer press either  button either the Print Screen key. Enter the name of the new screenshot in the window that should open:

![Screenshot name](image)

Figure 207. Entering the name of the screenshot

The window of the Print Screen tool will open. The new screenshot will be added to the folder selected before making it.

After pressing the button ✗ the making of the screenshot will be canceled. The window of the Print Screen tool will open.

If several interfaces are being previewed simultaneously and you want the semitransparent layer to be moved from one window to another, do the following:

➢ press the button ✗;
➢ click on the location to which you would like to move the layer.

The layer can be moved not only on the windows being previewed, but also to the windows of GUI Machine tools or to the windows of the application itself. For instance, the layer can be moved to a stack of floating panels.

![Covering a stack of floating panels with the semitransparent layer](image)
The location for the saved screenshots

All screenshots you make are saved to the directory of the project, to the folder *Screenshots*. 
14. User Manual and Information

To open this manual select Help → User Manual in the main menu.

To see the information about the program select Help → About program.

In the window shown on the figure above the following information is displayed in the tab General:

- information about the operating system;
- the version of JVM (Java Virtual Machine);
- GUI Machine official site;
- the participants of the projects and their e-mail addresses
  - developers;
  - testers;
  - designers
- the company that owns the license

In the tab Agreement the text of the license agreement is displayed. In the tab Third party software the information about the software of other developers used in GUI Machine is presented.
15. Feedback

To contact the developers select Help → Send us an e-mail:

The following window will open:

![Image of e-mail creation window]

Figure 210. Sending an e-mail message

Fill in the fields **Your name, Your E-mail, Subject** and enter the text of your message in the lower field.

You can add files and images to your message.

To add a file click on the button and select the file in the window that will open.
To add an image press 📸. The window described in 4.2.2.2. Image selection tool will open.

To add one more file press 📚.

To remove a file select it and press ❌.

You can up to 5 files whose size does not exceed 40 Mb.

The fields **GUI Machine version** and **License number** are filled in automatically and cannot be added. Press the **Send** button to send your message.

If you do not want to send the message, press the **Cancel** button.

To clear all fields and remove all files press the **Reset** button.
15. Keyboard shortcuts

The keyboard shortcuts used for the quick access to the application functions are described in the table below.

Table 41. Keyboard shortcuts

<table>
<thead>
<tr>
<th>Key combination</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>General</strong></td>
<td></td>
</tr>
<tr>
<td>Ctrl+N</td>
<td>Create a new project</td>
</tr>
<tr>
<td>Ctrl+O</td>
<td>Open a project</td>
</tr>
<tr>
<td>Ctrl+S</td>
<td>Save the project</td>
</tr>
<tr>
<td>Ctrl+Shift+S</td>
<td>Save the project as...</td>
</tr>
<tr>
<td>Ctrl+Q</td>
<td>Open the Image Export Tool</td>
</tr>
<tr>
<td>Ctrl+P</td>
<td>Print the project</td>
</tr>
<tr>
<td>Alt+F4</td>
<td>Close the project</td>
</tr>
<tr>
<td>Ctrl+T</td>
<td>Create a page</td>
</tr>
<tr>
<td>Ctrl+W</td>
<td>Delete a page</td>
</tr>
<tr>
<td>Ctrl+→</td>
<td>Go to the next page</td>
</tr>
<tr>
<td>Ctrl+←</td>
<td>Go to the previous page</td>
</tr>
<tr>
<td>Ctrl+Z</td>
<td>Cancel the last operation performed</td>
</tr>
<tr>
<td>Ctrl+R</td>
<td>Repeat the last cancel operation</td>
</tr>
<tr>
<td>Ctrl+H</td>
<td>Show/hide all tools</td>
</tr>
<tr>
<td>F12</td>
<td>Start the preview of the window/of the interface</td>
</tr>
<tr>
<td>F2</td>
<td>Rename the object</td>
</tr>
<tr>
<td>Ctrl+F2</td>
<td>Rename the page</td>
</tr>
<tr>
<td>Shift+F4</td>
<td>Allows to close the windows with the Allow closing window property disabled</td>
</tr>
<tr>
<td><strong>On the edit area</strong></td>
<td></td>
</tr>
<tr>
<td>Ctrl+C</td>
<td>Copy an object</td>
</tr>
<tr>
<td>Ctrl+X</td>
<td>Cut an object</td>
</tr>
<tr>
<td>Ctrl+V</td>
<td>Paste an object</td>
</tr>
<tr>
<td><strong>Ctrl+D</strong></td>
<td>Clone an object</td>
</tr>
<tr>
<td><strong>Ctrl+A</strong></td>
<td>Select all</td>
</tr>
<tr>
<td><strong>Ctrl+Shift+D</strong></td>
<td>Deselect all</td>
</tr>
<tr>
<td><strong>Ctrl+End</strong></td>
<td>Go to the right lower corner of the edit area</td>
</tr>
<tr>
<td><strong>Ctrl+Home</strong></td>
<td>Go to the left upper corner of the edit area</td>
</tr>
<tr>
<td><strong>Ctrl+Page Up</strong></td>
<td>A screen size shift to the left</td>
</tr>
<tr>
<td><strong>Ctrl+Page Down</strong></td>
<td>A screen size shift to the right</td>
</tr>
<tr>
<td><strong>Shift+→, ←, up и ли down</strong></td>
<td>Move object to the left, to the right, up or down</td>
</tr>
<tr>
<td><strong>Alt+→, down</strong></td>
<td>Increase the width or the height of the selected object</td>
</tr>
<tr>
<td><strong>Alt+←, up</strong></td>
<td>Reduce the width or the height of the selected object</td>
</tr>
<tr>
<td><strong>Page Up</strong></td>
<td>A screen size shift up</td>
</tr>
<tr>
<td><strong>Page Down</strong></td>
<td>A screen size shift down</td>
</tr>
<tr>
<td><strong>Delete</strong></td>
<td>Remove the selected objects</td>
</tr>
<tr>
<td>→, ←, up, down</td>
<td>Move the selected object to the right, to the left, up, down</td>
</tr>
<tr>
<td><strong>Space+mouse move</strong></td>
<td>Free edit area navigation</td>
</tr>
</tbody>
</table>

**In the Image Export tool**

| **Ctrl+End** | Go to the right lower corner of the workspace |
| **Ctrl+Home** | Go to the left upper corner of the workspace |
| **Ctrl+Page Up** | A screen size shift to the left |
| **Ctrl+Page Down** | A screen size shift to the right |
| **Page Up** | A screen size shift up |
| **Page Down** | A screen size shift down |
| **A** | Add a new image |
| **S** | Add a smart image |

**In the Print Screen tool**

| **Print Screen** | Take a picture of the area covered by the semitransparent layer. |
| **Enter** | Take a picture of the area covered by the semitransparent layer. |
16. Conclusion

**GUI Machine is a tool for successful interface design**

We have studied the existing GUI editing tools and united the most useful features and solutions in GUI Machine. We have also added a lot of unique features. With the help of GUI Machine it is possible to solve a wide range of problems related to GUI design.

*GUI Machine* has been used for designing interfaces in Alee Software company. It has proved the high quality. We hope our program will help you to solve complex problems within the shortest possible periods of time.

**The conception of constant development**

*GUI Machine* is a dynamically developing program.

Choosing GUI Machine you can be sure, that all your wishes, propositions and recommendations will be taken into consideration in the text versions. The program is constantly being improved and provided with new functions.

*GUI Machine* is a thoroughly supported product.

You can always contact our specialists if you have any problems concerning the work in GUI Machine. We will help you to surmount the difficulties and solve the problems.
Appendix 1. List of tables

The list of tables

Table 1. System requirements ........................................................................................................................................................................... 9
Table 2. Components ..................................................................................................................................................................................................... 63
Table 3. Standard object properties ................................................................................................................................................................. 69
Table 4. Properties for Editor ............................................................................................................................................................................... 71
Table 5. Properties of buttons ........................................................................................................................................................................... 71
Table 6. Properties for images .......................................................................................................................................................................... 73
Table 7. Properties for separators ................................................................................................................................................................. 74
Table 8. Properties for layouts ........................................................................................................................................................................ 74
Table 9. Properties for panels ........................................................................................................................................................................ 75
Table 10. Properties for split panels .............................................................................................................................................................. 76
Table 11. Properties for tabbed panels ......................................................................................................................................................... 76
Table 12. Properties for text fields and areas .................................................................................................................................................. 77
Table 13. Properties for the placeholder ...................................................................................................................................................... 78
Table 14. Properties for the progress bar .................................................................................................................................................... 79
Table 15. Properties for lists ........................................................................................................................................................................... 79
Table 16. Properties for the spinner ......................................................................................................................................................... 80
Table 17. Properties for the slider ............................................................................................................................................................... 80
Table 18. Properties for scrollbars ............................................................................................................................................................... 81
Table 19. Settings for trees ........................................................................................................................................................................... 82
Table 20. Properties for tables .................................................................................................................................................................... 83
Table 21. Properties for windows ............................................................................................................................................................... 84
Table 22. Properties for menus .................................................................................................................................................................. 85
Table 23. Properties for Google maps ...................................................................................................................................................... 86
Table 24. Properties for collapsible panes ................................................................................................................................................ 87
Table 25. Properties for clocks .................................................................................................................................................................... 88
Table 26. Properties for the audio player ................................................................................................................................................. 89
Table 27. Properties for the connector object .......................................................................................................................................... 89
Table 28. Properties for shapes ................................................................................................................................................................. 90
Table 29. Properties for data fields and calendars ................................................................................................................................ 90
Table 30. Properties for the tray icon ...................................................................................................................................................... 91
Table 31. Tools for working with layers .................................................................................................................................................... 114
Table 32. Tools for working with templates ........................................................................................................................................... 119
Table 33. Types of events ........................................................................................................................................................................ 165
Table 34. Types of actions ...................................................................................................................................................................... 170
Table 35. The tools of the Image panel ....................................................................................................................................................... 193
Table 36. The items of the context menu ................................................................................................................................................... 200
Table 37. Additional items of the context menu for menus .................................................................................................................... 203
Table 38. Additional context menu items for dynamic layouts ............................................................................................................. 205
Appendix 2. List of figures

List of figures

Figure 1. Language selection................................................................. 10
Figure 2. GUI Machine Setup Wizard................................................ 10
Figure 3. Destination directory selection......................................... 11
Figure 4. Manual directory selection................................................. 12
Figure 5. Creating file associations.................................................. 13
Figure 6. Selection of the location for shortcuts............................... 13
Figure 7. GUI Machine installation.................................................. 14
Figure 8. Installation completed....................................................... 15
Figure 9. The activation of GUI Machine......................................... 16
Figure 10. Entering the license key.................................................... 17
Figure 11. The information about the incorrect license key.............. 18
Figure 12. Information about the license.......................................... 19
Figure 13. License agreement............................................................ 20
Figure 14. Activation completed...................................................... 21
Figure 15. The dialog box offering to activate the license manually... 22
Figure 16. Activation code................................................................. 23
Figure 17. License information.......................................................... 24
Figure 18. Starting work in GUI Machine......................................... 25
Figure 19. Creating a new project..................................................... 26
Figure 20. Opening a project.............................................................. 27
Figure 21. Selecting a demo project to be loaded............................. 28
Figure 22. Tip of the day................................................................. 29
Figure 23. Launching the uninstall wizard...................................... 30
Figure 24. Uninstall completed........................................................ 31
Figure 25. The workspace of GUI Machine...................................... 32
Figure 26. The context menu for panels......................................... 33
Figure 27. Jointing panels................................................................. 34
Figure 28. Jointed panels................................................................. 35
Figure 29. Moving panels................................................................. 36
Figure 30. The main menu................................................................. 38
Figure 31. The File menu ................................................................. 38
Figure 32. The Edit menu................................................................. 39
Figure 33. Bold settings................................................................. 40
Figure 34. Text alignment................................................................. 40

Table 39. Image Editor Tools.............................................................. 209
Table 40. The Print Screen toolbar.................................................. 220
Table 41. Keyboard shortcuts........................................................... 227
<table>
<thead>
<tr>
<th>Figure</th>
<th>Description</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>83</td>
<td>Pop-up menu editor</td>
<td>106</td>
</tr>
<tr>
<td>84</td>
<td>A pop-up menu</td>
<td>106</td>
</tr>
<tr>
<td>85</td>
<td>Editing pop-up menu items</td>
<td>107</td>
</tr>
<tr>
<td>86</td>
<td>Editing HTML -text in popup menu items</td>
<td>107</td>
</tr>
<tr>
<td>87</td>
<td>Adding submenus to popup menu items</td>
<td>107</td>
</tr>
<tr>
<td>88</td>
<td>Menu editor</td>
<td>108</td>
</tr>
<tr>
<td>89</td>
<td>Editing HTML text in a menu item</td>
<td>108</td>
</tr>
<tr>
<td>90</td>
<td>The connection between the menu and the popup menu</td>
<td>109</td>
</tr>
<tr>
<td>91</td>
<td>Menu</td>
<td>109</td>
</tr>
<tr>
<td>92</td>
<td>Removing a popup menu</td>
<td>110</td>
</tr>
<tr>
<td>93</td>
<td>Selecting a cursor</td>
<td>111</td>
</tr>
<tr>
<td>94</td>
<td>Layers. The tree of objects</td>
<td>112</td>
</tr>
<tr>
<td>95</td>
<td>Context menu for the layers</td>
<td>113</td>
</tr>
<tr>
<td>96</td>
<td>The list of objects</td>
<td>113</td>
</tr>
<tr>
<td>97</td>
<td>The history of the project</td>
<td>116</td>
</tr>
<tr>
<td>98</td>
<td>History context menu</td>
<td>117</td>
</tr>
<tr>
<td>99</td>
<td>Colored history entries</td>
<td>117</td>
</tr>
<tr>
<td>100</td>
<td>User templates</td>
<td>119</td>
</tr>
<tr>
<td>101</td>
<td>Inserting an object</td>
<td>121</td>
</tr>
<tr>
<td>102</td>
<td>Selecting an object to be replaced by the placeholder</td>
<td>122</td>
</tr>
<tr>
<td>103</td>
<td>An interface based on a static layout</td>
<td>125</td>
</tr>
<tr>
<td>104</td>
<td>A static layout interface being previewed</td>
<td>125</td>
</tr>
<tr>
<td>105</td>
<td>Ruling a layout</td>
<td>126</td>
</tr>
<tr>
<td>106</td>
<td>Type of the size of the layout cells</td>
<td>127</td>
</tr>
<tr>
<td>107</td>
<td>Identification of rows and columns</td>
<td>128</td>
</tr>
<tr>
<td>108</td>
<td>Setting the size of layout zones</td>
<td>128</td>
</tr>
<tr>
<td>109</td>
<td>Stretching the object over two layout cells</td>
<td>129</td>
</tr>
<tr>
<td>110</td>
<td>Inserting an object in two layout cells</td>
<td>129</td>
</tr>
<tr>
<td>111</td>
<td>An error occurring at inserting an object into a dynamic layout</td>
<td>129</td>
</tr>
<tr>
<td>112</td>
<td>Changing the background of layout cells</td>
<td>130</td>
</tr>
<tr>
<td>113</td>
<td>Selecting cells to change the background</td>
<td>130</td>
</tr>
<tr>
<td>114</td>
<td>Background settings for layout cells</td>
<td>131</td>
</tr>
<tr>
<td>115</td>
<td>Selecting color</td>
<td>131</td>
</tr>
<tr>
<td>116</td>
<td>Gradient</td>
<td>132</td>
</tr>
<tr>
<td>117</td>
<td>Selecting an image</td>
<td>132</td>
</tr>
<tr>
<td>118</td>
<td>Selecting the image placement</td>
<td>133</td>
</tr>
<tr>
<td>119</td>
<td>Placing an image as a background image</td>
<td>133</td>
</tr>
<tr>
<td>120</td>
<td>Fitting to image size</td>
<td>134</td>
</tr>
<tr>
<td>121</td>
<td>Fitting to full image size</td>
<td>134</td>
</tr>
<tr>
<td>122</td>
<td>Settings for the alpha-layer</td>
<td>135</td>
</tr>
<tr>
<td>123</td>
<td>Settings for the background of cells</td>
<td>136</td>
</tr>
<tr>
<td>124</td>
<td>Previewing a layout</td>
<td>137</td>
</tr>
<tr>
<td>125</td>
<td>Changing the background of a single cell</td>
<td>137</td>
</tr>
<tr>
<td>126</td>
<td>Clearing the background of cells</td>
<td>138</td>
</tr>
</tbody>
</table>
Figure 210. Sending an e-mail message
Figure 209. Information about the program
Figure 208. Covering a stack of floating panels with the semitransparent layer
Figure 206. A screenshot of window content
Figure 205. Making a screenshot
Figure 204. Entering the name of the folder
Figure 203. The Print Screen tool.
Figure 202. PixelGrabber...
Figure 201. Image editor history tool...
Figure 200. Saving an image
Figure 193. The Image editor...
Figure 194. The main menu of the image editor...
Figure 195. The File menu...
Figure 196. The Edit menu of the image editor...
Figure 197. The Image menu...
Figure 198. The image size...
Figure 199. Canvas size...
Figure 207. Entering the name of the screenshot...
Figure 208. Covering a stack of floating panels with the semitransparent layer
Figure 209. Information about the program
Figure 210. Sending an e-mail message...